Sata Controller Failing? Strange hard drive problem.

Hi there,
I have a gigabyte ex58-ud3r. System runs Windows Vista (I know, I know - but it's a music creation PC - not connected to the internet and it has been stable and does what I need).

I am moderately savvy with installing hardware. I opened up the machine to put two new hard drives in with preinstalled software (data drives only). In order to authorize the software I temporarily hooked the computer up to the internet. Vista chose that moment to download updates and told me it needed a reboot.

Afterwards the machine wouldn't boot. It wouldn't even Post. I've done the usual troubleshooting items (check cables, memory, graphics card etc) I also ran CHKDSK on the OS hard drive and no errors were found. I have narrowed it down to this : I can get the machine to boot only if I unplug the SATA cable for theOS hard drive (the data harddrives are completely disconnected at this time) and plug it into a different SATA port. This works only for Port 2 and 3. Plugging into Ports 0 and 1 and the machine will not boot.

In my BIOS, the OS drive shows up only as an IDE slave. If I reboot, the machine will then not boot a second time until I switch SATA ports again.... It seems as though either the BIOS is Fubar after adding the two data drives (which are not now connected and do not show up in the BIOS) or either my ham hands or bad luck means that the SATA controller has taken this moment to take a dump...

Is there anyone out there who has any ideas on other things I can try, before forking out for a new MB?

Thanks
Ray
3 answers Last reply
More about sata controller failing strange hard drive problem
  1. Hi,
    I would firstly clear the CMOS (unplug the power cord and remove the CMOS battery for few minutes).
    Then connect only the OS drive to the SATA2_0 port. If still not booting, power off and connect the HDD to the GSATA2_0 port.
    If still no go, then I would test the HDD in a different system, to make sure it does work.
  2. You can also pick up a SATA controller card and by pass the motherboard ports http://www.newegg.com/Product/Product.aspx?Item=N82E16815158207
  3. Alexiou,
    Thanks for the tips. I tried as you suggested, first removing the power cord and CMOS battery and then trying the Sata_0 and GSata_0. No change.

    I think the harddrive is fine. I can get it to boot. I just have to unplug and then replug the Sata cable into the Sata_2 port. However if I restart the machine, it will not boot again until I unplug and replug the Sata cable... I guess it's functional, just a hassle and a weird problem. I'm reluctant to mess with the data drives I need to plug in until I sort this out.

    Maybe I'll pick up a SATA controller card. I can plug a OS drive into one of these and have no hard drive plugged into the motherboard?
Ask a new question

Read More

SATA Controller Windows Vista Hard Drives Motherboards