Sign-in / Sign-up
Your question

ASUS M5A97 R2.0 Motherboard LAN Problem

Tags:
  • DNS Server
  • LAN
  • Routers
  • Motherboards
  • Asus
  • Windows 7
Last response: in Motherboards
March 19, 2013 8:53:17 PM

I built my first PC, it was so much fun but the last problem I expected there to be was a software problem.
I had the latest LAN driver from: http://www.asus.com/Motherboards/M5A97_R20/#support_Dow... on a USB, copied it to the desktop and installed it, along side Chipset, Audio, USB and I think that was all. I hooked the new PC up to the router and the router to an RCA broadband modem, the same way this PC is, on the same router and hardware.. powered down and up about 12 times now, the most I get is "The DNS server isn't responding." with a yellow "!"

So then.. I ran the disk that came with the M5A97 and nothing changed, except maybe now I have outdated drivers. I'm very frustrated and compounded with that I am using a 2004 Dell Dimension that the owner doesn't take care of, it's freezing and I need to get this question out there. I greatly appreciate any help, thank you!

Edit- Possibly this is a Windows 7 Home 64 bit problem or error, one of the two.

More about : asus m5a97 motherboard lan problem

a c 811 V Motherboard
a c 108 Ĉ ASUS
a b $ Windows 7
March 19, 2013 9:56:15 PM

Open the Windows 7 Control Panel>then select Network and Internet> then Network and Sharing Center
Go to the change your network settings list
Select set up a new connection
a c 105 V Motherboard
a c 100 Ĉ ASUS
March 20, 2013 2:51:23 AM

Keep using the latest LAN drivers, check device manager to make sure there are no issues with installation of the driver (there will be a warning next to the LAN device). If all checks out, then there is some kind of configuration issue in the OS or a connection problem between the PC and router. Check the computer is being issued an IP address from the router. DHCP will auto configure the client PC with gateway details by default when you make a physical LAN connection via Ethernet.

Related resources
March 20, 2013 5:54:11 AM

The worst part is that to try these fixes I have to first shut off this PC and unplug it, so I have no internet when I unhook the router. There are many ways people have fixed this on PC's old and new, I've tried every one of them and still nothing. I knew nothing about PC's a month ago, now I've built my own and cannot use it or the thousand dollars I spent on it.
I truly appreciate you guys taking the time to help.
Calvin, I tried what you suggested and still would not connect, but maybe I'm missing an important step, like I said I'm less than competent when it comes to routers and setting these things up.
raja, everything is alright with device manager, there is no indication of a problem, my boot screen has only one fan error.. there is definitely a connection problem from what I can tell. I'm going to look into the IP, but last time I was checking either the sent or received data wasn't transferring, I think it was receiving but not sending. I'm sorry I wish I could remember, I didn't sleep lastnight, worked out at 2am and just worried all through work. I'm going to see if a new router will work.. and /or calling a technician over from my ISP company.. and /or taking it to Best Buy, though I don't think they'll deduce or conclude what the problem is at all, I am grasping at straws and I don't know what to do.

Edit- Probably normal but the ethernet hook-up on the back end of the PC lights up orange (or possibly a light red) and yellow, I was expecting green or blue, not to mention I think that error would have been obvious by now.. I spent a day building it and I was extremely careful. I'm going to check the BIOS again, when I figure out how to access it, though everything seemed ok, I tried my best to consider every partition.

Update- I have successfully changed the SSID on my new PC using Calvin's advice, that's a tiny bit of progress.. I checked that through Belkin router ip address: http://192.168.2.1/
a c 1429 V Motherboard
a c 430 Ĉ ASUS
a b $ Windows 7
March 20, 2013 6:56:20 AM

Hi, some thoughts:
-the router might have the MAC filter enabled, therefore denying the new network controller connection.
-if able to configure the router, you can try resetting it to default.
-you can also skip the router and directly connect to the modem. But the Internet connection has to be configured, depending on the ISP (username and password).
March 20, 2013 7:15:59 AM

Thank you alex, I'm in that process right now and I've concluded that a firewall in the router is blocking my access: Firewall log:
Sat Jan 1 00:00:12 2000 1 Blocked by DoS protection 192.168.2.3

The date is obviously incorrect, as I mentioned I am unplugging both computers everytime to try a new solution. Your guys' help is invaluable to me, if I get this working it will be the nicest, most multifunctional thing I think I've ever owned, so you can imagine my disposition when something so stupid is making my perfect PC useless to me.
a c 1429 V Motherboard
a c 430 Ĉ ASUS
a b $ Windows 7
March 20, 2013 8:29:30 AM

If typing “http://router” or 192.168.2.1 in IE or other browser, on the new computer, are you able to access the router interface?
March 20, 2013 9:44:21 AM

Well, I was thinking of trying that, but since I edited the configuration with this computer, those changes should stay even when I power down and connect to the new PC, even as painfully slow as this one is it can handle box checking and saving.
I was on the phone with my ISP's representative and he had me perform a test. I plugged the router straight to the new PC via ethernet connector and the signal stayed the same, data was sending and receiving, the router was enabled, but no internet. Then we ran the cord from the modem into the PC and instead of reaching the network (PC to Network to Internet diagram at the top of the explorer,) there was no connection at all. Maybe he was trying to rule out the cord being the problem, maybe none of that is useful at all. I was planning on looking at Best Buy's selection of modems, routers and ethernet cords anyhow, this lan hardware I have has seen its prime.
It still begs the question, why will it work perfectly on this old PC, but not on my new one? Couldn't be the firewall, since I did a factory restore there hasn't been another blocked entry. Someone mentioned this and may have worded it differently, when this type of router or modem is connected to one PC for a prolonged period of time, it can be somewhat hardwired to be used for that specific PC.. They didn't have a solution, just that it would be difficult to undo - just one of many questions that are plaguing me. Thanks again.

P.S. My sincerest apologies, moderators, for bringing this from a hardware issue, to software, back to hardware, to a router problem. I never would have guessed this would occur