Sign in with
Sign up | Sign in
Your question

Windows half-recognizes USB flash drive

Last response: in Windows 7
Share
March 24, 2013 9:36:33 PM

I'm running windows 7 and I also have a XP box on oracle VM (this will become relevant in the following explanation). My problem is: Until yesterday my pendrive was recognized, I could read and write files, everything was normal, today it's not.

Every other USB works correctly (mouse, printer, keyboard), and now comes the really unexpected part: for some obscure reason oracle virtualbox recognizes my pendrive, and I can mount it on my xp box! I can actually access it normally while inside the xp box, but not on my windows 7. This makes me believe that, somehow, Windows is recognizing it but not... making it available, though I'm not sure this even makes sense, technically speaking.

Following recommendations, I went to "Disk management", and surprisingly it recognizes my removable disk, however, it only recognizes it as "Disk 1 - Removable" and nothing else, while VM Virtualbox recognizes it as "Kingstom data traveller". ScreenShot of Disk Management] and ScreenShot of Vbox

I also discovered another interesting thing: My neighbour happens to have a flash drive too, so I asked for his for testing purposes, and surprisingly it presents the exact same problems as mine (I should point out that coincidently, both flash drives are "Kingston data travellers", even though his is 4gb and mine 8gb, sadly I don't have a non-Kingston flash drive to test)
How can I fix this situation?
Thanks in advance!
Edit: I would like to point out that :
-I already tried Hardware Device Problems Fix-it from microsoft.
-I already tried different USB slots.
-I already went to "Device manager", unninstalled "Usb mass storage" , removed the USB and reinserted the USB. I was then prompted with "Installing new device", "Install successful", but afterwards I still couldn't access the flash drive.
-I went to cmd > "diskpart" and tried to enable "automount", but it was useless, since it was already enabled.
-I tried directly going to the driver it was supposed to be mounted in (G:/) directly, even though it didn't appear in "my computer" (Without success, obviously)
-I also tried rebooting after doing all of the above.
March 25, 2013 6:14:02 AM

Oh, I forgot to add, I had already tried a system restore point. Doing a Repair install seems like overkill, don't get me wrong, I will do it iff it's really required, but isn't there a less drastic solution? I'm willing to try anything.
Related resources
a b $ Windows 7
March 25, 2013 6:33:32 AM

I guess it's the Windows Explorer component of the Operating System that is at fault, there's no way I know of re-installing that. You could try running chkdsk to see if an error could be found and repaired.
Run Command prompt as Administrator
Start, type cmd, Rt click CMD and choose 'Run as admin'
Type chkdsk /f /r (note spaces preceding /) then Enter.
type Y and enter to run the programme when you restart Windows
Expect it to take a long time if you have a large drive. Use this to check out the chkdsk log to see what was found. If many errors found it may indicate your HDD failing
http://www.sevenforums.com/tutorials/96938-check-disk-c...

Might be worth while backing up the drive and formatting it, preferably on a Win 7 machine...
March 25, 2013 6:54:02 AM

"Windows has found no bad sectors"

Oh well, I think I'm just going to format it anyways.
a b $ Windows 7
March 25, 2013 7:12:36 AM

Jane Shizuka said:
"Windows has found no bad sectors"

Oh well, I think I'm just going to format it anyways.

Meant format the Flash Drive 1st!

!