Sign in with
Sign up | Sign in
Your question

No sound from Media Player after updating BIOS - Gigabyte Z68-UD4-B3

Last response: in Motherboards
Share
a c 125 V Motherboard
March 25, 2013 1:45:26 AM

Hi all.

I have a Gigabyte Z68-UD4-B3 MB with onboard Realtek sound and Windows 8 Pro X64. I use the latest K-lite Codec Pack with both Windows Media Center and MPC.

Sound has been working fine until I updated the BIOS today. Strange thing is that system generated sounds, like the various Pings and Bongs that Windows makes play just fine, it's only content that I try to play through a media player, such as an AVI or MKV file where the sound is silent.

The BIOS update was from version U1C to U1E(UEFI BIOS). It's my understanding that this is a one way update. At least I don't see any way to downgrade back to the previous version.

Anyone else with this MB having this issue? Anyone have a clue as to how I can troubleshoot this further?

I made sure to reset the BIOS to optimized defaults after updating, and I have checked that the onboard audio is enabled.

Thanks for any help.
a b * Windows 8
a c 558 V Motherboard
March 25, 2013 2:30:54 AM

Hi,
What is listed in Tools/Options/Devices ?
a c 125 V Motherboard
March 25, 2013 2:37:36 AM

OK. Rather than suffer through playing with Gigabyte's buggy UEFI BIOS for this MB, I found a way to downgrade the BIOS back to the latest version of the legacy BIOS. All is working now.

Thanks.
Related resources
May 13, 2013 9:27:22 PM

i m having same problem with same mb, do u think u can tell me how u downgrade back to whatever bios?
a c 125 V Motherboard
May 13, 2013 9:43:52 PM

Go to http://forums.tweaktown.com/gigabyte/28441-gigabyte-lat...
Download UEFI back to AWARD in the z68 category
Click on Previous BetaBIOS in the z68 category
Download GA-Z68X-UD4-B3 - F10e
Prepare a DOS bootable USB flash drive formatted to FAT32, and copy the contents of both download archives onto the flash drive.
Boot from the USB flash drive, and follow the instructions in the readme to execute EFI2AWD.exe <bios filename> and begin the flash process.
May 14, 2013 9:20:22 AM

abekl said:
Go to http://forums.tweaktown.com/gigabyte/28441-gigabyte-lat...
Download UEFI back to AWARD in the z68 category
Click on Previous BetaBIOS in the z68 category
Download GA-Z68X-UD4-B3 - F10e
Prepare a DOS bootable USB flash drive formatted to FAT32, and copy the contents of both download archives onto the flash drive.
Boot from the USB flash drive, and follow the instructions in the readme to execute EFI2AWD.exe <bios filename> and begin the flash process.


thanks, fixed
!