New high end amd system getting LOW FPS

Ok so i have an fx-6300 with a hd 7950 3gb. and a 970 board. with 8gb of 1600 g.skill ram and a 575W diabloteck psu. and im getting less Fps than i was getting with my phenom 1 X4 2.4 and a 550ti. Please help me.

Obv i can play games at much higher details. But even in lower setting my framerate has gone to shit.

Games i play:
Crysis 3 (must play on low-med)
battlefield 3 (seems to work on high)
SWTOR (surprised i cant max)
League of legends (LESS THAN 50 FPS IN LOWEST SETTINGS! W!T!F!)
Hawken (less than 60 fps ALWAYS)
World of tanks (cant go anywhere near high settings and low settings dont help much)
Vindictus (30 fps avg, this is not that great looking of a game)
Planetside 2 (30fps, tho i hear this is normal for the game as very cpu intensive)
BIOSHOCK INFINITE (very low settings 30 fps)

ALL games have v-sync disabled and no fps cap programs in place (not new to this)

I have fresh install of win 8, with 13.3 or whatever latest beta drivers.
GPU is OC to 1000mhz and 1500 mem. CPU is stock.
Temps are normal and hardly a factor.
cpu RARELY bottlenecks (if ever, usually below 70%)
dunno how to test the load on my gpu, but im having a hard time believing a 7950 could be bottlenecking me this much.

PLEASE HELP ME WTF IS WRONG!

Also for league of legends I KNOW i was playing at CAPPED 60 fps. Now below 50. For such a simple game i cannot understand how im not getting WAY higher fps.
30 answers Last reply
More about high end amd system low fps
  1. Do you have MLAA and/or v-sync forced on in the CCC? V-sync sounds likely.

    You should try running 3dmark11, and post the results in performance mode. That should let us know if you have a setting on or you have hardware/software issues.
  2. bystander said:
    Do you have MLAA and/or v-sync forced on in the CCC? V-sync sounds likely.

    You should try running 3dmark11, and post the results in performance mode. That should let us know if you have a setting on or you have hardware/software issues.


    ok, checked amd vision engine control center.. and vsync say to "application settings" and AA is at "multisampling" but there is no "off" or "disabled" i think this is just what kind of sampling it uses.. not whether it uses it or not.. and everything else is at "use application settings"

    Im dl 3dmark right now.. but i've run Unigine and got a score of 2000
    Is this normal?
  3. Fast answeres helpfull... Running out of time to exchange for another 7950 and i need to know if its the problem.
  4. Do you have v-sync on in games?

    Also, MLAA is its own checkbox, not part of the MSAA slider like the rest of the AA options.
  5. Should be getting around 2400 on the 3dmark 11 test according to a quick search on google. Maybe outdated drivers could be the culprit?
  6. Cyanide Reverse said:
    Should be getting around 2400 on the 3dmark 11 test according to a quick search on google. Maybe outdated drivers could be the culprit?


    Your 3dmark11 score should be around P8000-P9000, and about 9k-10k on the graphical score. What is it you are getting? Don't run it in extreme, use the performance preset.
  7. Ok.. So...

    Just ran 3dmark 11 and i got:
    SCORE
    P6730 with AMD Radeon HD 7950(1x) and AMD FX-6300
    Graphics Score 7865
    Physics Score 4707
    Combined Score 4686

    However its 3dmark11 BASIC in 720P
    it wont let me do extreme (1080) without paying.


    And unigine scores between 2000-2100

    I did notice during the 3dmark test i was failing miserably at the Physics. with sub 15 fps. however it says i scored well... is this normal then?

    Also, I have resinstalled drivers MULTIPLE times. As well as plugged in my laptop v of win 8 to test if its soft issues. Unless im missing something cause my gpu drivers are the latest.

    Vsynch is off on every game. if theres an game side fps cap its set to max or benchmark.
  8. Ah the 2400 was on extreme this is where I got it from:

    http://www.techpowerup.com/159284/Radeon-HD-7950-Put-Through-3DMark-11.html
  9. Cyanide Reverse said:
    Ah the 2400 was on extreme this is where I got it from:

    http://www.techpowerup.com/159284/Radeon-HD-7950-Put-Through-3DMark-11.html


    Well, the graphics score is about what I've been finding when doing a google search, so the card is performing normal. However, the low overall score is a result of your CPU giving poor physics scores. It could also be a bottleneck in games. You might want to check the temps to make sure its not overheating (the CPU).
  10. when i run prime95 on my cpu i get a constant 60-65C. I dont see how my games running at <80% could be causing more heat than that.
  11. You may be running normal. Though I suspect in game settings on some of those games has v-sync on. I know many online games tend to not go to very high FPS as well. Even if they seem like they are easy. Online games tend to have CPU and internet requirements that keep you slower than offline games.

    3dmark11 found your 7950 to be in normal range. Your CPU is obviously your weak link.
  12. is it holding up to a normal fx-6300?

    I know i have the turbo core disabled im turning it on as we speak.
  13. Discipleoflife said:
    is it holding up to a normal fx-6300?

    I know i have the turbo core disabled im turning it on as we speak.


    One way to check is to use MSI Afterburner and check the GPU load when gaming. If it is being held back by the CPU, the load will be low. OCing the CPU and using the turbo, would also help know if it helps, as your FPS will increase.
  14. Sigh.. i turned on turbo core and disabled my power settings. because the fisrt run it showed my cpu as being at 1.4ghz... which is the lowest my powersetting will drop it.. but i set it to run at constant 3.5. the test showed turbo core as it reported it at 3.8 but yet i still got low physx scores! :(
    SCORE
    P6790 with AMD Radeon HD 7950(1x) and AMD FX-6300
    Graphics Score 7949
    Physics Score 4710
    Combined Score 4745

    I dont know whats up. I know AMD is behind intel in games. but not THIS behind right? is there something wrong with my cpu?
  15. Keep in mind, thi sis heavily OC'ed, but it seems your score is within range, especially if that is all at stock clocks.
    http://www.3dmark.com/3dm11/5636754
  16. Unless im an idiot. There isnt drivers for the CPU right? I have chipset drivers. but i dunno. I've had this cpu for barely a month. -.- but i think i cant rma it anymore :(
  17. Your score, on the page, it should tell you if your score is normal for your system. They are pretty accurate with that these days, as they do factor in clocks now.
  18. bystander said:
    Keep in mind, thi sis heavily OC'ed, but it seems your score is within range, especially if that is all at stock clocks.
    http://www.3dmark.com/3dm11/5636754


    It says that cpu has 8 cores on a 6300.. and 4.9 wow... didnt know u could oc it that high. also his 7950 is getting a 10000 score when mine is getting 7000. Whats with that? just that little bit extra oc? So then... do i need to overclock my comp to play leage of legends at 60fps? cause i did that back on my phenom 1 2.4 / 550ti as well as when the fx had the ti. So i dont see how a processor upgrade could result in less performance...

    it seemed like when i first installed my gpu card it was running faster than this. -.- either im just a bad stoner with bad memory. or its actually performing worse. is maxed league with 60 fps really unattainable?

    Would temporary overheating cause the cpu to degrade? myb somehow it overheated at one point and i didnt notice?

    I was looking at overclocking as a "later on" thing as im jobless. i guess stock 6300 just cant cut it? I guess im going to need to look into an evo 212. just would had to overclock the cpu and find out there still is something wrong.
  19. He is obviously a heavy OCer, and your score was a lot better than 7000, it was 7900. That's a big difference, and puts it in the normal category for a non-OC'ed card.
  20. bystander said:
    He is obviously a heavy OCer, and your score was a lot better than 7000, it was 7900. That's a big difference, and puts it in the normal category for a non-OC'ed card.


    is there another test that can confirm its the cpu? So what would ur suggestion be for my cpu? is it simply lost? should i get another? or would another 6300 be just as bad? Do i NEED to oc it? cause right now most games are unplayable. and this whole mess is making me wanna cry :(
  21. If you want high end FPS consistently, you'll want a high end Intel CPU. The high end AMD CPU's will be hit and miss in games, depending on whether they need fast cores or like more cores. You have an AMD CPU that would be fine if you were ok with 40ish FPS in some games.

    Crysis 3 is a CPU killer, you pretty much need to go high end or go home. You also cannot expect to "max" most games. PC games have sliders, and high end options not meant to be used by most people.

    Btw, are those numbers are average, max, or minimums?
  22. The fps are avg. I understand i cant max crysis 3. but on high i run at like 27 fps, and on low i run at 34 ish. Battlefield 3 runs at 40+ish avg high which i guess is awesome. but most games running 30-40ish avg which means dips sometimes down into the 10s and that is NOT what i expect. most games grpahic settings dont change much. However its my LOW end games taht are showing the problem. Such as league on high and BS:I on VERY LOW. (i have moar like it) that are ALSO in the 30-50ish range. Which with the notorios microstutter and fps drops makes it quite hard to play. I turn the graphics down on leauge to low and i get 100s fps but i could play league on very high with NEVER below 60 with my 550ti with same processor. I use league as my expample because its the lowest graphics game i can think of.
  23. It does sound like something is an issue. Perhaps you need to update your drivers and BIOS. Checkout GPU-Z, make sure the bus interface is correct, see if you have enough PSU power, which can cause throttling. See if the CPU is overheating, that sort of thing.
  24. Well, i definitely know something is up, because all the sudden it has stopped.
    I didnt really do anything to fix it. But im getting 100S fps in league and MUCH better Fps in my higher end games.
    While im super glad its working right now, I do still wonder what might have caused the problem so i can avoid it next time.
    lol.
    THANK YOU BYSTANDER! Your responses were quick and helpful.
    I'll post again if the problem resurfaces. (please dear god no)
    I've give you a cookie, but internet cookies taste like cardboard.
    So i will just say, If i have another problem someday, I hope your still on the forum!

    THANK YOU
  25. You don't happen to have a backup system, or scanning system that was going on during your tests the other day?
  26. if the problem happens again, try downgrading drivers, and if you take fps limiter off league of legends you should easily get +300 fps since im getting around 150-200 on a hd5850 & fx-6100
  27. no backup system.
    and no scanning systems (probably should get at least antivirus)

    However, I think myb bittorrent was runing in the background..
    I swear i checked to make sure it wasnt, but maybe i missed it.
    if so the constant downloading would cause the fps/slow hdd.
    Altho i dont have it set to start on windows, and i tried restarting several times. So maybe that wasnt the problem.

    @chromic: I definitly am still not getting 300fps on it. However i go from 100-160. Which is MORE than acceptable for me.

    BS:I is running on ultra at 60-80 FPS. up from the 30 on low.
    SWTOR is running about 5-10 fps better (good considering its main slowing factor is the many people and not the gfx so im pleased. and im getting 40+ in the fleet. WHICH IS AWESOME.

    Crysis still runs like shit. But you need like 5 computers transmuted together to run that thing on high 60+ lol.

    Overall, im getting the fps i expect with this top end card.

    However, I wonder if there is a way to squeeze out some extra fps.
    Any tips on how to optimize for games? I know there are certain services that can be disable for the avg user. and some optimization tweaks. if anyone knows anything about this and willing to help. My computer is basically ONLY for gaming. I know my HDD is slow as molasis (5200rpm) and i've heard something about a ramdisk? putting files directly on ur ram for fast loading? anyone know anything? Itd be awesome if i could do that for games that use on demand loading untill i can afford a SSD or 7200.

    OH! and one more thing. Does anyone know how to set up Physx with an AMD primary and nvidia dedicated physx? I did some basic googling, but it was all a little confusing, requiring special drivers (which im fine with as long as the work as well)
    I know generally its not worth it. But i do play like 3-4 games that include Physx regularly (hawken, BS:I i think has it, Planetside, forgot if crysis does, and i think farcry3). And i have an old 9800GT (or 550ti but i need a higher psu for that. Myb it doesnt need the 6pin for just physx?) i could use.

    Neways im rambling on. I havent tested 3d mark since its performance has improved. When i get home i will post the benchmark, hopefully my cpu will perform better.
  28. try downloading latest non-beta drivers, you could see an improvement, one time i had beta drivers and bf3 ran 40 fps and micro freezed every other min, then i downgraded the drivers to non-beta and had a nice +50 fps and no problems.

    same with borderlands 2, 40-70 fps with beta 50-90 with non-beta

    and bittorrent / utorrent shouldnt be decreasing fps in games, mainly only your ping increases by 10-200 ( depending on your internet speed )
  29. so get this. I found old nvidia drivers on my pc. I uninstalled them. and upon next reboot. I have no picture. board does not have onboard as far as i cant tell. (i see a port but its male and my cord is male. Think it might be serial)
    I can put my old 9800gt in toone get around this but wondering if anyone thats knows if its possible to install drivers with some kind of usb live boot or something?

    This also means that maybe somehow my 7950 was running on the driver for my 550ti (right?) which i didnt know was possible. but would explain my bad fps myb.
  30. so get this. I found old nvidia drivers on my pc. I uninstalled them. and upon next reboot. I have no picture. board does not have onboard as far as i cant tell. (i see a port but its male and my cord is male. Think it might be serial)
    I can put my old 9800gt in toone get around this but wondering if anyone thats knows if its possible to install drivers with some kind of usb live boot or something?

    This also means that maybe somehow my 7950 was running on the driver for my 550ti (right?) which i didnt know was possible. but would explain my bad fps myb.
Ask a new question

Read More

7950 3gb fx-6300 Low FPS AMD Games FPS Graphics