Solved

HDMI Connection Problem in GTX 660 Ti Graphics Card to Monitor Samsung S22B370

My new custom rig Configuration is as follows,
Asus P8Z77-V Motherboard
i5-3450 Processor
Gskill RipjawsX 8GB RAM
Palit GTX660 Ti JetStream 2GB Graphics Card
Samsung S22B370 LED Monitor
This monitor has a HDMI port so I have bought a Prolink HDMI Cable and tried to connect it with the HDMI port of my graphics card. But my monitor showing "no signal check connection" massage. I have also tried to connect it with the HDMI port in my mobo but same problem. In this circumstances what I need to do to fix this problem? Please help me.
I have connected my HD D2H Set top box with this monitor using same HDMI cable but in this situation it is working. So where is the problem? Please help me.
3 answers Last reply Best Answer
More about hdmi connection problem gtx 660 graphics card monitor samsung s22b370
  1. Best answer
    AniChatt said:
    My new custom rig Configuration is as follows,
    Asus P8Z77-V Motherboard
    i5-3450 Processor
    Gskill RipjawsX 8GB RAM
    Palit GTX660 Ti JetStream 2GB Graphics Card
    Samsung S22B370 LED Monitor
    This monitor has a HDMI port so I have bought a Prolink HDMI Cable and tried to connect it with the HDMI port of my graphics card. But my monitor showing "no signal check connection" massage. I have also tried to connect it with the HDMI port in my mobo but same problem. In this circumstances what I need to do to fix this problem? Please help me.
    I have connected my HD D2H Set top box with this monitor using same HDMI cable but in this situation it is working. So where is the problem? Please help me.


    Reseat your GPU & make sure it's in the socket properly. Make sure the wire isn't fault and make sure your TV received HDMI from different devices. If nothing works then use the standard display on your system...delete all 3rd party video drivers & install the ones that came with your GPU or the latest ones off the Palit site.
  2. ihsaan96 said:
    AniChatt said:
    My new custom rig Configuration is as follows,
    Asus P8Z77-V Motherboard
    i5-3450 Processor
    Gskill RipjawsX 8GB RAM
    Palit GTX660 Ti JetStream 2GB Graphics Card
    Samsung S22B370 LED Monitor
    This monitor has a HDMI port so I have bought a Prolink HDMI Cable and tried to connect it with the HDMI port of my graphics card. But my monitor showing "no signal check connection" massage. I have also tried to connect it with the HDMI port in my mobo but same problem. In this circumstances what I need to do to fix this problem? Please help me.
    I have connected my HD D2H Set top box with this monitor using same HDMI cable but in this situation it is working. So where is the problem? Please help me.


    Reseat your GPU & make sure it's in the socket properly. Make sure the wire isn't fault and make sure your TV received HDMI from different devices. If nothing works then use the standard display on your system...delete all 3rd party video drivers & install the ones that came with your GPU or the latest ones off the Palit site.


    Thanks a lot for helping. I have updated nvidia graphics driver and restarted my pc. Now it is working. Thanks again......
  3. AniChatt said:
    ihsaan96 said:
    AniChatt said:
    My new custom rig Configuration is as follows,
    Asus P8Z77-V Motherboard
    i5-3450 Processor
    Gskill RipjawsX 8GB RAM
    Palit GTX660 Ti JetStream 2GB Graphics Card
    Samsung S22B370 LED Monitor
    This monitor has a HDMI port so I have bought a Prolink HDMI Cable and tried to connect it with the HDMI port of my graphics card. But my monitor showing "no signal check connection" massage. I have also tried to connect it with the HDMI port in my mobo but same problem. In this circumstances what I need to do to fix this problem? Please help me.
    I have connected my HD D2H Set top box with this monitor using same HDMI cable but in this situation it is working. So where is the problem? Please help me.


    Reseat your GPU & make sure it's in the socket properly. Make sure the wire isn't fault and make sure your TV received HDMI from different devices. If nothing works then use the standard display on your system...delete all 3rd party video drivers & install the ones that came with your GPU or the latest ones off the Palit site.


    Thanks a lot for helping. I have updated nvidia graphics driver and restarted my pc. Now it is working. Thanks again......


    It's alright , I'm glad to help :)
Ask a new question

Read More

HDMI Gtx Connection Peripherals Graphics Cards Monitors