Sign in with
Sign up | Sign in
Your question

i7 3770k under performing in benchmarks

Last response: in CPUs
Share
May 21, 2013 10:19:31 AM

hello all,
I think i have a bottleneck issue maybe but i'm not exactly sure what.I looked everywhere i could for any kind of idea as to why but I cant find anything. I just want to make sure the cpu is performing like other 3770k's. I'm getting a score of 7.18 in Cinebench benchmark utility.Others running at 3.5ghz with stock factory settings are getting 7.6-7.9 or more on average from what i found:??: .I have the second latest version of the bios which is only a few months old.My ram is running at the stock speed of 2133mhz,no turbo mode, everything else is set to default. Not sure what i'm doing wrong but i checked just about everything i could think of.The cpu is not throttling,temps are within reasonable range i think with a stock cooler (67c max under load measured with realtemp), and there are absolutely no other processes or applications running in the background with a basic display scheme.Also the power save mode is set to performance in windows 7.According to cpuid it reads 3.5ghz when under load and speed step brings it down to 1.6ghz like normal at idle. I'm pretty insanely o.c.d when i spend alot of money on something so i want to make sure its running properly. Do i even need to update the bios to the absolute latest version?Does the cpu need a better cooler?(the cooler is seated properly and the TIM was applied properly.)And is anybody willing to compare benches in cinebench to get an idea of what is average for these cpus at stock?Any help would be greatly appreciated.
specs:win 7 64bit (all drivers are up to date)
(Win7 performance index also specifies 7.8 for the cpu.)
Asus P8Z77-V LK
Intel i7 3770k
G.skill ddr3 2133mhz
Gigabyte Radeon hd 7970oc
WD 1tb black edition hard drive
Antec 630w psu
corsair case with 5 120mm fans.
a b à CPUs
May 21, 2013 10:28:45 AM

Turn turbo mode on and try again.
May 21, 2013 10:33:30 AM

elemein said:
Turn turbo mode on and try again.


Update:when i turn it on, It overclocks to 3.9ghz like it should...I want to know if others are getting the same benchmark scores with 3.5 ghz stock.Anybody?
Also it hits 77 degrees C when running Cinebench at 3.9ghz turbomode. Is this normal?not to mention its only a score of 7.87.
It didnt throttle that i could see. I also updated the bios and it didnt really help at all.If anybody could give me some pointers on certain settings in the bios that would be great.Anything.Please i know somebody can help me understand this.
!