Sign in with
Sign up | Sign in
Your question

after plugging in cosair vengeance, my computer wont boot up.

Last response: in Memory
Share
May 25, 2013 2:25:41 PM

after plugging in my new cosair vengeance, it computer wont get pass the OEM loading screen. i tried opening bios but its practically stuck. so what should i do?

here is my previous and new ram.




i just recently installed a r7970 black edition overclocked. just incase it has something to do with my ram problems.

here is my components.
videocard = xfx 7970 black EDITION
powersupply = Extreme Gaming Series 1000w
motherboard = xtreme design motherboard p7p55d-e LX
HDD = desktar hitachi 7,200 RPM 32mb/mo
processor = intel core i3 cpu g40 @ 3.07 ghz
ram = 4gb
May 25, 2013 2:36:34 PM

What are the specs for that particular memory? Did you install it into the slots coordinated in your motherboard manual? Have you updated your BIOS? Have you made sure that it's installed properly? Have you tried booting with just 1 stick installed?
Related resources
May 25, 2013 2:57:09 PM

Throw in your old RAM, get a USB stick, download a program called Rufus and make it bootable device. Then download the latest BIOS from Asus' website and place it in the root directory on the USB drive. Then you just flash it from there through the BIOS.

I'd still love to hear the specs of the RAM you bought.
May 25, 2013 3:09:21 PM

You've enabled the XMP profile from BIOS right?
May 25, 2013 3:09:43 PM

btw, i dont have a usb at the moment but i have a 2gb external drive.. would it be possible i use my external drive instead of buying a usb?
May 25, 2013 3:10:43 PM

i havent enabled it yet. and i dont know how to. im just a newbie trying to learn stuff at the moment.
May 25, 2013 3:11:44 PM

Depends on the connectivity. If it's e-sata or USB then you should be OK.
May 25, 2013 3:13:58 PM

its by USB.
May 25, 2013 6:25:55 PM

bump. i really need help installing my new RAMs.
a c 80 } Memory
May 25, 2013 8:03:47 PM

Because your CPU is the i3 that only supports 1333MHz RAM, and the new one is 1600MHz that means you need do the OC RAM in the BIOS, but I thinks the old RAM maybe can't OC to 1600MHz. So you are better set the RAM mode to the XMP in the BIOS. Or manual set the RAM speed to 1333MHz in the BIOS.

Download the manual from ASUS website, go to page 2-11 section 2.4.2 "Ai overclock tuner" change "auto" to "X.M.P." and then save, exit the bios setting. http://www.asus.com/Motherboards/P7P55DE_LX/#support_Do...

If the PC still can't boot up then you need update the bios, go to the same website download the bios utilities, then update the bios.


May 26, 2013 6:00:56 PM

to no avail. i can open 1 ram in the bios but if i plug in both. it doesnt start up it goes to windows(loading to user profiles screen) and restarts everytime.

btw i already updated bios.
a c 80 } Memory
May 27, 2013 6:13:26 AM

I think one of them is dead, test the RAM one by one to see which is dead. If they are ok. Then check the sock of MB to see there is bent pin or not.
May 27, 2013 6:38:42 AM

i tried them both.and both went to bios single plugged. but after that. i couldnt pass the windows loadingscreen again. i would get a blue screen. if one of the pin in the MB is bent, would the old ram not work too?
a c 80 } Memory
May 27, 2013 7:47:12 AM

If both of them don't pass the window screen during the boot, and you set the XMP setting, that means the RAM is not compatible with i3 and MB.
!