Sign in with
Sign up | Sign in
Your question

Toshiba External Hard drive wont work on USB 3.0 but will on 2.0

Last response: in General UK & Ireland Discussions
Share
June 1, 2013 10:59:20 AM

Hi (Again).

I have a toshiba stor.e 1tb - USB3

It was working on my laptop (Only USB2)
I recently built a new PC with USB 3 and tried my drive, it lit up blue rather than white. But Windows did not do anything about it. Not in my computer or anything. Thanks
June 1, 2013 11:53:33 PM

It might be worth look in Control Panel>Administrative Tools>Event Viewer to see what the System log has to say about what happened when you plugged it in. Manufacturers have a lot of cute tricks to make us spend money by updating hardware to the point where other hardware can't work.

Yesterday I tried to install a HP LaserJet 1000 on to a Samsung laptop running Windows 8. It failed to find a driver but at least I go a message saying the USB Printer Port didn't have a driver for USB 3.0. I would have expected you to see the same message. Maybe it's i the Event Viewer.
December 1, 2013 7:16:05 AM

I have a Hitachi 500 external that has a blue 3 USB connector it does not work when connected to the PC blue 3 USB. It does work when connected to the PC and laptop black 2 USB.
See: W7 wants to format used external, it may be of help.
Related resources
December 1, 2013 7:42:28 AM

Maybe it showed up as a drive without a letter assigned to it. Plug it in again and look in Control Panel>Administrative Tools>Computer Management>Disk Management. If it's there, you can assign a letter to make it show up in My Computer.

In Control Panel>Device Manager, does the USB 3.0 port show as installed and working, without power saving enabled?
December 1, 2013 10:35:22 AM

Saga Lout said:
Maybe it showed up as a drive without a letter assigned to it. Plug it in again and look in Control Panel>Administrative Tools>Computer Management>Disk Management. If it's there, you can assign a letter to make it show up in My Computer.

In Control Panel>Device Manager, does the USB 3.0 port show as installed and working, without power saving enabled?


1 - It did show in Disk Management once as drive H and once as disc 3 - 465 GB. I did not change the drive letter as things went slow and things disappeared. I have not tried to use the blue 3 USB connection since. I'd rather not mess up the PC. I may try it later and your suggestion to change the drive letter but for now I'll try to find out more about why it doesn't work from the blue 3 USB.

2 - In Device manager - without power saving enabled - R click does not show or in USB 3 properties, it does show that it is working properly.

Thank you for your reply.
December 1, 2013 10:56:08 AM

Skod said:
12072998,0,360357 said:

2 - In Device manager - without power saving enabled - R click does not show or in USB 3 properties, it does show that it is working properly.
said:


No - it suggests it isn't working at all. If Disable is an option in the right click menu, do that then restart and see if it reinstalls itself in a better frame of mind. If you have the motherboard drivers disk handy, put ti in the drive just in case.
!