Sign in with
Sign up | Sign in
Your question

Won't display / boot / all the lights on keyboard is on

Last response: in Graphics & Displays
Share
June 6, 2013 4:17:44 PM

I just bought a graphic-card with water colling (Evga GTX 580 Hydro Copper)
and installed it in my computer and it wouldn't display anything. So when I tried to put in the first graphic-card (7800 GTO) it would still not display anything, and I noticed that the RAM was getting really really warm, couldn't hold on it for more than about 5-7 seconds from startup. I have tried to change back, change the cpu with another and RAM with some other RAM. Still no communication with the pc, no display, no way to get into bios, tried everything. Could it be that the MB is broken? Can something happend with the water that caused something?

PC stats (before insalling new hardware when all worked) :
Asus formula IV AM3+
AMD Phenom II X6 1090T Processor, Black Edition
Corsair Vengeance 1600mHz
Corsair SSD
7800 GTO
Corsair CX 430W

PC stats (Last known for not working)
Asus formula IV AM3+
AMD Phenom II X6 1090T Processor, Black Edition
Corsair Veneance 1600mHz
Corsair SSD
Evga GTX 580
Corsair CX 430W

Would really like a respons or help on this topic, else I wind up buying new MB, RAM and CPU for the pc.

a c 189 U Graphics card
June 6, 2013 10:33:17 PM

Have you tried start it up without RAM? Does it make "beeps" sound?
June 9, 2013 2:58:56 PM

wa1 said:
Have you tried start it up without RAM? Does it make "beeps" sound?


yes, but nothing, it is a total black screen, no startup, all the Scroll > num and caps lock lights are on, not even the regular blink... probably a good buy for the whole comp.
Related resources
!