Sign in with
Sign up | Sign in
Your question

My Desktop Keeps Shuttingdown/freezing/going black while Gaming

Tags:
Last response: in Video Games
Share
June 9, 2013 6:24:03 AM

So last week, I suddenly started to face an issue where my monitor would suddenly say "No Signal" while gaming. I knew something was wrong when the in- game music would turn into a loud, odd buzzing, as if the computer had corrupted or something (I am not tech savvy) and would stay like that for a while. Not sure how long it would go on for because after 5-10 minutes, I would manually shut it down. Other times, the same thing would happen, but then the computer would turn off. AND other times, the same thing would happen, but it would restart, then turn off, then restart, then turn off, etc. This is a very odd sequence of errors, if I say so myself. I've tried a virus check, a malware check and everything. Then I tried a system restore to some point in time, not that far, and all of a sudden, my problem had disappeared. Everything was fine until today - one week later. The computer shuts down while I game, but this time when I turned it on, I would get no display on my monitor. So i turned the power supply switch off, and then after a while of waiting, I would switch it back on and it would work. But yeah, the error still persists. I find it rather odd that moving back to a certain point in time would fix the issue for a while. Doesn't that mean it isn't a hardware issue? I don't think it is a graphics card problem because in the time period where my gaming was fine, my FPS and everything was normal.

My event viewer says "The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly."

My temperatures are normal; they hover around the 35-50 range.

Please help me fix this issue.

EDIT: I just woke up to turn on my PC, now I don`t get any display. All the fans are running and everything. Does this occur with a faulty in PSU as well, or is this a seperate issue. I`m using my laptop to write this BTW.

Need help asap. This is really annoying.

EDIT2: After a million attempts at turning on and off the computer, it finally starts to show up on my screen...

EDIT3: Ok now it`s not even when gaming. It turns off simply when on the windows/desktop screen.

EXTREMELY frustrating. Please help me..
a b 4 Gaming
June 9, 2013 10:05:56 AM

Are there any beeping sounds at all.

June 9, 2013 11:43:15 AM

X79 said:
Are there any beeping sounds at all.


No
a b 4 Gaming
June 9, 2013 11:57:26 AM

Perhaps it's the PSU.
!