Sign in with
Sign up | Sign in
Your question

Ethernet port not working / Can't connect to internet

Last response: in Motherboards
Share
June 19, 2013 6:36:04 PM

Hey everyone, I'm posting this on behalf of my friend who is having an issue with her Ethernet port not working properly. She has given me all the details of her problem and we're just looking for solutions/advice - thanks in advance.

She has an ancient HP desktop. :)  If there is no more that can be done to resolve this issue then we would really appreciate suggestions for an affordable PCI Ethernet adapter.

Computer Specs:
OS: Windows 7 home premium 32-bit
Motherboard: ECS Nettle3 (Socket AM2 )
CPU: AMD Athlon 64 X2 4600+
RAM: 3.00GB Single-Channel DDR2
GPU: EW24T7EW NVIDIA (HP)

Background information:
- problem started happening 6/18/13
- left the PC on overnight
- came home from work at 4pm; internet was not working
- checked other devices and internet had no issues, only on desktop

Tried:
- Restarting PC and Modem/Router several times
- Swapped Ethernet cables
- Tried changing Ethernet ports on Modem/Router
- Found most recent update for my Ethernet software
- Did a system restore before most recent updates (update was 6/16/13)
- Backed up data to external drive
- Reformatted
- Installed Ethernet software again
- Restarted PC; still no internet access

Not sure she dusted out the ports, but I suggested that to her.
a b α HP
a c 1504 V Motherboard
June 19, 2013 7:02:36 PM

Are all the proper light on the modem on and Green (or the proper color? Power, INT, DSL, Ethernet are a set of 4 typical ones.. in case the modems gone bad and check with your provider, they can poll the modem to see if it's good....if all settings were lost, for some reason they can also talk you through a manual set up on the system of either a static or DHCP assigned IP address,.if so am guessing a PCI 10/100 or 10/100/1000 ethernet card sounds like the answer...could try a CMOS rest of the motherboard to reset the adapter to factory default - (will have to reset system time after), but that's about it off top of my head - looks like you've gone through all the typical steps
November 15, 2013 8:35:10 AM

hello guys, i have the same problem and i tried everything which is mentioned here, but i cant solve it. I cant connect via ethernet(wireless is OK), but it connects with others pc, so the problem is my pc. when i go to see the properties of the connection, there is a physical adress full of 0... i read somewhere that the problem might be the fact that i moved in the UK from Greece, and i have to make some configurations, is that possible??? If you want i can attach what i get from the ipconfig.. Please help guys!

cheers
daniel
Related resources
a b α HP
a c 1504 V Motherboard
November 15, 2013 8:42:33 AM

Yep, might be, when in Greece it may have set your network settings to a static IP that won't talk to your current modem/router, might uninstall the the network (ethernet contoller), temp disable the wireless, then reinstall the ethernet driver and run through the Network wizard in Win, hace the details from your ISP handy for the network info
November 15, 2013 9:24:21 AM

thanks, but is there anywhere that i can find the steps in more details? coz, i dont want to mess any configuration..
a b α HP
a c 1504 V Motherboard
November 15, 2013 1:31:22 PM

Try the Network and Sharing Center in Win - it can take you through setting up a new ethernet connection
!