/ Sign-up
Your question

Game play is slow and choppy when look around, Please HELP!!!!

  • Games
  • Graphics
Last response: in Graphics Cards
June 28, 2013 2:47:29 PM

Hi everyone,

I'm new to Tom's Hardware and looking for some help. I have listed my system I just built and having a bit of trouble gaming. So my problem is that when I start a game (batman arkham city and asylum, and crisis 2) and look around with my mouse its very slow and choppy. Changing my graphics level has not helped my problem and lowering my mouse speed has not fixed it either. Does anyone have any ideas why my movement (look around) is so slow?

Motherboard: Sabertooth 990fx
CPU: AMD 8150 (overclocked to 4.7 and stable)
-Watercooled with Corsair h100i
PSU: Coolermaster 850w
RAM: 16gb Patriot Sector 5 1600mhz
Fans Everywhere
GPU: Diamond 5870 eyefinity 6 (2gb) [in crossfire]
Sapphire 5870 eyefinity 6 (2gb)
Boot up HDD: 128gb SSD
Programs HDD: seagate 2tb 7200rpm (this is where my games is coming from)

More about : game play slow choppy

June 28, 2013 2:49:45 PM

Are you running anything like MSI afterburner or EVGA precision? If not download and play those games again and report what your gpu usage is in them
June 28, 2013 2:54:43 PM

You're either limited by a CPU, out of video RAM, or it's loading data off a hard disk.

Considering you're playing games that are not extremely demanding you should not be out of video RAM if you actually have 2GB on each card (or are you combining both together to make 2GB total?). With 16GB of system RAM you should not be loading off the hard disk.

If your CPU is really stable at 4.7GHz that should not be a limit (unless it's throttling due to over temp).

Like Intel God suggested: check and monitor your CPU usage, GPU usage, and temps on both. Report back with those as that could give us insight.

EDIT: You listed Eyefinity. What resolution are your three monitors?
Related resources
June 28, 2013 3:20:05 PM

cargod4490 said:
Here is CPU-Z pic for my processor. I have performed multiple stability tests with multiple programs and have had no errors or problems. My gpu's are 2gb each. And would running off a 7200rpm harddrive really make my look around in games so choppy? Never had a problem like that with a laptop.

We need a gpu usage shot after you play a game.
June 28, 2013 3:20:24 PM

cargod4490 said:
Here is CPU-Z pic for my processor. I have performed multiple stability tests with multiple programs and have had no errors or problems. My gpu's are 2gb each. And would running off a 7200rpm harddrive really make my look around in games so choppy? Never had a problem like that with a laptop.

The Hard Disk may take more time to LOAD the game than an SSD. But once it's loaded into memory the hard disk is meaningless. You have 16GB of system ram and 2GB of video ram. With those titles that should NOT be the problem.

Your GPU temps are fine. However, GPU 1 is at 35% usage while GPU2 is at 0%. Was this shot while you were playing or while you were sitting at the desktop? If this is while you're playing your problem may be that your Crossfire isn't working. Or, that your CPU is keeping your video card from doing anything.

CPU-Z confirms you are OC'd to 4.65GHz. What's the CPU temp?
June 28, 2013 3:25:21 PM

Dang my picture taking was slow. Yes they both will run, it only goes to 0% due to the idle feature. My crossfire is definitely on. My CPU temps never get close to 50C when I was stress testing then it can get to like 53C. Any ideas with maybe my settings? I dont know what settings could be causing this :/ 

And my videos are fine and smooth, and when i play games like starcraft 2 and League of Legends I have no problems. This is why im so lost.
June 28, 2013 3:43:37 PM

So ultimately we still need to see the GPU usage stats during gameplay. Leave Afterburner open while you play the game for a few minutes. Then take the screenshot after exiting so we can see how much load is put on the GPUs.

Also - What resolution are your monitors? You listed Eyefinity which suggests you're using 3 monitors. That can be fairly taxing.
June 28, 2013 6:14:42 PM

Im just running my games off one 23" monitor that is 1920x1080. I said eyefinity due to the vram being increased on that card from 1gb to 2gb. So if i dont look around the game is great smooth and perfect, its only when i look around i have the choppy lag. I have attached a pic of afterburner when im running. Its interesting how my 2nd card isnt hardly running :/  any thoughts? crossfire is on, and i have a bridge.
June 28, 2013 7:41:02 PM

Just an update I did some researching and I had my game in window and that doesnt allow crossfire to be utilized. So I put it in window and here are the afterburner results. Still having the same problem, if i dont look around i have a great fps like above 80fps but once i look around there is the lag. any ideas yall?
June 28, 2013 8:12:48 PM

Go to and download the latest driver. It looks like there is a newer driver for your card (assuming you're using Win 7)

See if the updated driver helps.

Do you have PhysX disabled in Batman? I'd be curious to see what your CPU usage is compared to the GPU. Primarily I'm wondering if the CPU usage spikes during the dips on the GPU chart.
June 28, 2013 9:05:43 PM

I will download and take a screenshot of afterburner when i play batman arkham city
June 28, 2013 10:53:19 PM

How does it run with crossfire disabled? Could be crossfire related stuttering although it seems alittle extreme for that.

How much background stuff do you have?
June 29, 2013 3:22:32 PM

Drivers are all up to date. here is pic of my game settings and afterburner results while in crossfire (just a little bit of gaming. I'm not running to much in background either

With crossfire disabled it is still choppy when i look around. :/  anyone have any idea why my look around in games is horrible? Games are unbearable when you cant look around
June 29, 2013 7:50:49 PM

**Important update everyone**

So I used my keyboard and mouse all in one and started my game and it was smooth as can be. Any idea why my mouse, Razer Orochi, is causing this??????? The driver is up to date but still is causing me to lag. Hooking it up through blue tooth doesn't fix it and plugging it into a different usb port doesnt fix it. Any Ideas?????
July 1, 2013 11:39:53 AM

I'm presuming it's a wireless mouse/keyboard? Hate those things.

I'm a fixed wire kind of guy personally.

You could try Uninstalling the drivers for the mouse/keyboard setup. Then let windows install it's own generic driver. See if they work without the manufacturer's software.
July 1, 2013 12:41:05 PM

Thanks jerreece for you insight. I agree im a wired guy as well. after buying 2 additional mouses and returning them (due to having the same effect) i finally found something on lowering the polling rate of the mouse. the razer orochi has polling rates of 125hz, 500hz, and 1000hz. I tried the 500hz and 1000hz but then found that having a polling rate of 125 fixed someones problem (similar to mine) I then tried it and bingo!! fixed my problem. I now have fantastic gameplay and excellent look around. Thanks for everyone's insight on my matter :)