Sign in with
Sign up | Sign in
Your question

Aero glass effects not working despite GTX 580 installed

Last response: in Windows 7
Share
August 5, 2013 9:28:41 AM

I've had a problem for months where my Aero Glass effects have simply not worked. I ran the Microsoft Fix It program to try and solve it, but it told me that my graphics card is not compatible with Windows Aero. My graphics card is an nVidia GTX 580. I also have a GTS 450 installed and ran the program again with the video coming out of the 450, but again Microsoft lies to me telling me that that it is not compatible either. I don't know what to do. I got to the next bit where it says you can send your troubleshooting report to Microsoft, and that comes up with an error every time, and I am getting the Captcha correct every time. Could anybody help me sort this out?
Thanks.
August 5, 2013 11:02:30 AM

theclouds said:
A sure way to solve this problem will be to start over. Use drive sweeper to remove all your Nvidia drivers. Download here: http://www.guru3d.com/content_page/guru3d_driver_sweepe.... Reboot. Go to Nvidia and reinstall your drivers. Use this: http://www.nvidia.com/Download/Scan.aspx. Reboot. Go to Control Panel. Appearance and Personalisation. Click Personalisation. Aero Theme.


Thanks. When I remove the drivers, do I select to clean the display, PhysX and chipset? The chipset drivers have something to do with the registry, it says.
August 5, 2013 11:17:23 AM

theclouds said:
A sure way to solve this problem will be to start over. Use drive sweeper to remove all your Nvidia drivers. Download here: http://www.guru3d.com/content_page/guru3d_driver_sweepe.... Reboot. Go to Nvidia and reinstall your drivers. Use this: http://www.nvidia.com/Download/Scan.aspx. Reboot. Go to Control Panel. Appearance and Personalisation. Click Personalisation. Aero Theme.


I've also looked this up elsewhere and there are lots of people saying that DriverSweeper does more harm than good and that the nVidia installer will wipe the old drivers anyway. What should I do?
August 5, 2013 11:34:46 AM

theclouds said:
A sure way to solve this problem will be to start over. Use drive sweeper to remove all your Nvidia drivers. Download here: http://www.guru3d.com/content_page/guru3d_driver_sweepe.... Reboot. Go to Nvidia and reinstall your drivers. Use this: http://www.nvidia.com/Download/Scan.aspx. Reboot. Go to Control Panel. Appearance and Personalisation. Click Personalisation. Aero Theme.


I've done everything perfectly and nothing's worked. What else can I do?
a b U Graphics card
a b $ Windows 7
August 5, 2013 11:35:52 AM

All three. You'll get them back when you reinstall through the nVidia installer.

christianwolff said:
I've also looked this up elsewhere and there are lots of people saying that DriverSweeper does more harm than good and that the nVidia installer will wipe the old drivers anyway. What should I do?


It will not do any harm. When you remove the nVidia drivers Windows will default to its own basic display drivers which are designed to work with a wide range of cards. Okay for regular computing, but not good for gaming. So long as you install the nVidia drivers you'll be in a better situation than you were before bc even if it doesn't work you have eliminated driver conflict from the equation.
August 5, 2013 11:37:22 AM

theclouds said:
All three. You'll get them back when you reinstall through the nVidia installer.

christianwolff said:
I've also looked this up elsewhere and there are lots of people saying that DriverSweeper does more harm than good and that the nVidia installer will wipe the old drivers anyway. What should I do?


It will not do any harm. When you remove the nVidia drivers Windows will default to its own basic display drivers which are designed to work with a wide range of cards. Okay for regular computing, but not good for gaming. So long as you install the nVidia drivers you'll be in a better situation than you were before bc even if it doesn't work you have eliminated driver conflict from the equation.


It didn't work, I'm afraid. The glass effect won't appear. Anything else you can recommend?
a b U Graphics card
a b $ Windows 7
August 5, 2013 11:43:41 AM

That's okay. The reason I suggested reinstalling drivers was to make sure Windows recognized the card and not a generic display adapter.

Next, I'm under the impression you had the 450 first and aero was working. It was only until the 580 was added that aero quit.

Try using Aero Troubleshooter. Type aero in the search programs and files box, select find problems with transparency and other visual effects.

http://support.microsoft.com/kb/976170/en-us

This will list nearly all potential contributors.

EDIT: If the utility doesn't fix it, list the troubleshoot report and we'll work from there.
August 5, 2013 11:58:49 AM

theclouds said:
That's okay. The reason I suggested reinstalling drivers was to make sure Windows recognized the card and not a generic display adapter.

Next, I'm under the impression you had the 450 first and aero was working. It was only until the 580 was added that aero quit.

Try using Aero Troubleshooter. Type aero in the search programs and files box, select find problems with transparency and other visual effects.

http://support.microsoft.com/kb/976170/en-us

This will list nearly all potential contributors.
EDIT: If the utility doesn't fix it, list the troubleshoot report and we'll work from there.


It was the other way round. The 580 is my main card and the 450 is my PhysX card. I've used the 580, single monitor, as the main display card since I bought the computer.
The troubleshooter says it couldn't identify the problem.

Aero

Potential issues that were checked
Mirror drivers don't support Aero effects Issue not present
Aero effects not supported on this Windows edition Issue not present
Video card driver doesn't support Aero effects Issue not present
The Windows Experience Index has not been computed Issue not present
Potential issues that were checked

Mirror drivers don't support Aero effects A running program uses a mirror driver (a type of display driver) which is not compatible with the Aero desktop experience.
The Windows Experience Index has not been computed The Windows Experience Index base score measures the capability of your computer's hardware and software configuration and is one of many factors that determine whether the Aero desktop effects can run. Detection details

Collection information Computer Name: CHRISTIAN-PC Windows Version: 6.1 Architecture: amd64 Time: Monday, August 05, 2013 7:47:54 PM Publisher details

Aero Display Aero effects such as transparency. Package Version: 1.0 Publisher: Microsoft Windows
Aero Display Aero effects such as transparency. Package Version: 1.0 Publisher: Microsoft Corporation
Issue not present Issue not present Issue not present Issue not present
Issue not present
Aero effects not supported on this Windows edition Some Aero features such as transparency are not included on certain Windows editions.
Issue not present
Video card driver doesn't support Aero effects The current video card driver isn't compatible with the Windows Display Driver Model (WDDM).
Issue not present
Issue not present

a b U Graphics card
a b $ Windows 7
August 5, 2013 12:12:49 PM

This would have been easier.

http://go.microsoft.com/?linkid=9740812&entrypointid=FI...

So aero was working with 580 but ceased to work upon the addition of the 450? I'm asking to see if this configuration might offer clues.


EDIT: Just finished skimming through your post..I wanted to provide you with possible solutions while I read through your post.

**Aero effects not supported on this Windows edition
Some Aero features such as transparency are not included on certain Windows editions.**

Which version of Windows do you have installed? I ask bc:
----
How do I get the Aero desktop experience?

The following editions of Windows 7 include Aero:

Windows 7 Enterprise

Windows 7 Home Premium

Windows 7 Professional

Windows 7 Ultimate

Aero is not included in Windows 7 Home Basic or Windows 7 Starter. You can find out which edition of Windows 7 you have on your computer by opening System in Control Panel.
----
August 5, 2013 12:25:15 PM

When I bought the computer, both the 580 and 450 were installed, with the 450 as PhysX. I have Windows 7 Professional.
a b U Graphics card
a b $ Windows 7
August 5, 2013 1:04:57 PM

So when you bought the computer Aero effects were enabled. It was only until recently it stopped working. Correct?

Try to backtrack what changes were made to the system from the time it was working.

Meanwhile, assuming everything was working when you got your computer, both the 580 and 450 are seated correctly, proper drivers are installed, you should see GTX 580 and 450 under Displayed adapters in Device Manager. It should not read generic Display Adapter.

One last thing is to restart Desktop Windows Manager.
Run CMD as Admin.
Type
net stop uxsms
net start uxsms
August 5, 2013 1:12:08 PM

I've done all of that, still doesn't work. Yes, when I bought it, Aero effects worked. A few months ago, I did a System Restore back to before when the Aero disappeared. For a few weeks after that, Aero reappeared. Then, having not installed anything for fear of it happening again, the Aero disappeared as quickly as it did before.
a b U Graphics card
a b $ Windows 7
August 5, 2013 1:19:08 PM

If drivers and hardware checks out, you should at least be able to force transparency. Go to Personalisation then Window Color, there should be a box to tick off for transparency.
August 5, 2013 1:20:52 PM

There's no checkbox, just 'Window Color and Appearance.'
a b U Graphics card
a b $ Windows 7
August 5, 2013 1:36:03 PM

Type services.msc, scroll down the list and look for Themes. Check the Status is set to Started and Automatic.

Make sure you aren't using any third part theme program that may override the Aero effects you are trying to enable.

EDIT: Good luck.
August 5, 2013 1:46:21 PM

Still nope. I've started to uninstall as many needless programs as I can to get to the source of the problem, but I can find nothing. The only thing I can think of is to repair Windows somehow.
a b U Graphics card
a b $ Windows 7
August 6, 2013 9:11:52 AM

Odd how the Transparency Box is unavailable for selection. Try finding this option by going to Control Panel select Visual Effects. Make sure Enable Transparent Glass is checked under Custom.

Last option: Try this. Save it. Right Click to Merge. Allow. Reboot.
!