Sign in with
Sign up | Sign in
Your question

Serious Stuttering and Performance Issues - Something is wrong...

Tags:
  • Performance
  • Games
  • Graphics
Last response: in Graphics & Displays
Share
August 8, 2013 7:03:39 PM

I hope this is the right topic forum. I've essentially forgotten what walking through an area in a game smoothly looks like in the past couple of days, and all of my trouble shooting has failed. In every single game I run, I get ridiculous stuttering, hitching, skipping, whatever you want to call it. In a few occasions a game's performance will start out decent (still with skipping) and then just plummet into the teens, using Metro: LL as an example. Something is wrong, and I can't for the life of me figure out what it is. Otherwise, framerates are embarrassingly low across the board and even old games like Bad Company 2, that my old rig used to run perfectly, now stutters and hitches as well.

Gigabyte 770 4GB
i5 2500k @ stock clocks
8GB RAM

I'd like to say it's bottlenecking, but I'm not sure and honestly am not familiar with having issues with my PC's performance. My hunch is that, in my attempts at overclocking my CPU, I have fucked it up in some way or another. Temperatures never got above 60fps, and even with apparently stable overclocks, performance wouldn't change or would in some cases be worse. I don't think my RAM is corrupt and my GPU is less than two months old, so I sure as hell hope there isn't anything wrong with that.

I'm getting a bit desperate here, as I'm leaving for school in just under a week and want to make sure my PC's performance is reliable for my brother while I'm gone. I'll try and cooperate to figure out what exactly is wrong here.

More about : stuttering performance issues wrong

August 8, 2013 9:29:38 PM

Not sure if this helps but I had a weird stuttering problem and an update of my drivers did the trick... maybe try contacting either Nvidia or gigabyte about the problem?

Also... not to make you worry but just because something is new doesn't mean it's not a lemon. I've had a couple instances where I've received DOA brand new parts after ordering them.
August 9, 2013 10:51:29 AM

gtonic said:
Not sure if this helps but I had a weird stuttering problem and an update of my drivers did the trick... maybe try contacting either Nvidia or gigabyte about the problem?

Also... not to make you worry but just because something is new doesn't mean it's not a lemon. I've had a couple instances where I've received DOA brand new parts after ordering them.


This actually worked for the time being. Did a clean install of the most recent Nvidia drivers and things are much, much smoother. Not perfect/as good as I expect them to be given 770 benchmarks, but not bad.
August 9, 2013 11:50:04 AM

RoKKeR said:
gtonic said:
Not sure if this helps but I had a weird stuttering problem and an update of my drivers did the trick... maybe try contacting either Nvidia or gigabyte about the problem?

Also... not to make you worry but just because something is new doesn't mean it's not a lemon. I've had a couple instances where I've received DOA brand new parts after ordering them.


This actually worked for the time being. Did a clean install of the most recent Nvidia drivers and things are much, much smoother. Not perfect/as good as I expect them to be given 770 benchmarks, but not bad.


Well glad to see it helped :D 
!