Sign in with
Sign up | Sign in
Your question

New build won't even let me access BIOS

Last response: in Motherboards
Share
August 10, 2013 9:30:30 AM

Main Specs:
Intel Core i5-3350P 3.1GHz (No inbuilt graphics)
Gigabyte GA-Z77-D3H ATX LGA1155 (rev 1.0)
Corsair Vengeance (2 x 4GB) DDR3-1600Mhz
EVGA GeForce GTX 760 2GB
Corsair CX 600W ATX 12V

Also: Samsung 840 SSD, Seagate 1TB HDD, Windows 7 64bit, LG GH24NS95 DVD/CD Writer

I have just built a new PC from all new parts mentioned above but when I go to turn it on, the display is completely non-responsive at the pre-bios screen, which says press Del for bios setup, F9 system information, F12 Boot menu, END Q-flash. After a while the screen will go black.

It is not a problem with the keyboard as I have tried both usb and Ps2 keyboards in all available slots. I have also rechecked and made sure everything is plugged in correctly. As I can't even access BIOS and it won't boot from the windows 7 disc, is it a problem with the motherboard?

More about : build access bios

a c 559 V Motherboard
August 10, 2013 9:39:38 AM

Hi, Try clearing the CMOS firstly (unplug the power cord and remove the CMOS battery for few minutes) then leave only one RAM stick, GPU, DVD-drive, keyboard and mouse and start the board.
August 10, 2013 10:36:24 AM

alexoiu said:
Hi, Try clearing the CMOS firstly (unplug the power cord and remove the CMOS battery for few minutes) then leave only one RAM stick, GPU, DVD-drive, keyboard and mouse and start the board.


Hi, thanks, for replying. However I tried what you said and the problem's still there. Is it possibly do to with the motherboard revision?

a c 559 V Motherboard
August 10, 2013 11:25:50 AM

The CPU is supported, so no.
Try taking the board outside the case and test again.
!