My GPU Clock Speed's locked?!

My Powercolor Radoen HD 7770 Ghz Edition is supposed to run at, well, 1 Ghz. It used to be fine like, yesterday, but now it's runnign a core clock of 300 mhz and a memory clock of 150 mhz. someone please help. I've tried OC in AMD VISION Engine control center. Even MSI afterburner says i'm running at those speeds. It never changes even when I play games.

The weird part is, I can play Planetside 2 like this. I figured at those speeds it wouldnt even render lol.

What's going on? can someone help? Thanks,

4 answers Last reply
More about gpu clock speed locked
  1. Wow, no one knows anything? Well I "refreshed" my computer, got GPU-Z and it fixed the problem. I downloaded MSI Afterburner and it had no info on my Graphics card. This was because I did not have the drivers for my GPU. I went on AMD and got the drivers and the Catalyst Control Center, then the problem was back. I think I'm just going to remove the control center I'm tired of this. :(
  2. What if you adjust the clock speed manually?
  3. It goes to 300Mhz at idle, check you actually have something running.
  4. Ok so I am currently using a beta AMD Catalyst Control Center. I Enable Graphics overdrive and adjusted it. Now it kicks in when I'm on a graphic demanding website or game. IT DID NOT even do this before. I don't know exactly what I did but now it works under load.

    I guess I was just confused because with my old GPU you could still watch the clock go up and down between like 150mhz and 400mhz, even at idle. This one stays at 300mhz core clock and 150mhz memory clock, even as I'm loading and logging into Runescape. As soon as I enter a world, however, then it clocks up. I thought this was strange. I guess it just doesn't need to clock up until then.
Ask a new question

Read More

GPUs Locked GPU Speed Graphics Cards Graphics