Sign in with
Sign up | Sign in
Your question

7870 Graphics card issue when install drivers.

Last response: in Graphics & Displays
Share
August 20, 2013 9:58:39 AM

Hello, I am currently experiencing an issue, my pc works fine when I don't have any drivers installed for my graphics card on my computer however when install the drivers this happens after reboot: http://www.youtube.com/watch?v=2kPjZ-_SuRg
Any information that can help me would be great thanks in advance.
August 20, 2013 3:00:41 PM

Sorry i forgot to mention i did a clean install of windows 7 formatting the hdd so there are no previous drivers.
Related resources
a b \ Driver
a c 210 U Graphics card
August 20, 2013 3:22:01 PM

When you say you don't have any drivers installed, I presume you mean you are using the Win7 supplied driver. At that time, are you getting the full native resolution of your monitor? Or is it a generic 1024x768?
August 20, 2013 3:40:13 PM

Yes, i am using the windows supplied drivers. i am getting 1600x1200 resolution. however it reboots me into 1920x1200 and still gets the lines but doesn't crash.
a b \ Driver
a c 210 U Graphics card
August 20, 2013 3:53:56 PM

OK. Then you are probably using the Win7's AMD driver. As a work-around, just be sure to download/install the App Profiles too. You won't loose much (if anything) by not having the very latest drivers. And Windows will auto update the driver as it receives new ones.

But that doesn't solve the issue, I realize, as to why this is happening. Very strange that this should happen only with the official AMD driver. I presume you are using the correct driver for your card and OS. How are you connected to the monitor?

Try this... run Driver Sweeper from Safe Mode and have it remove any AMD, ATI, and Nvidia graphic driver remnants it finds. Re-boot and re-install the latest AMD driver for your card and OS.
Driver Sweeper: http://www.techspot.com/downloads/4266-driver-sweeper.h...
AMD Driver: http://sites.amd.com/us/game/downloads/Pages/downloads....
August 20, 2013 4:14:16 PM

Still the same problem with the lines but has stopped crashing, it also comes up with a MOM.exe error message when i log in and when i try and open AMD vision centre it also comes up with an error message.
a b \ Driver
a c 210 U Graphics card
August 20, 2013 7:16:42 PM

Do you have all your Windows updates installed? That sounds like what happens when there is no .NET framework 4.x installed. Check your updates to see if you have any of the .NET framework 4 series installed. Then do a update check.
!