Sign in with
Sign up | Sign in
Your question

i7 870 and HD 7990 and Far Cry 3

Last response: in Graphics & Displays
Share
August 23, 2013 12:59:54 PM

Hi.

I have an AMD HD 7990, an i7 870 (not overclocked) and 8gb of RAM and I'm getting stuttering gameplay in Far Cry 3.

I am assuming this card can handle the 'ultra' settings but it's set to 'optimal' at the moment.

Also, both GPUs are running at nearly 100% activity. Can this be right? Any ideas what's going on? I'm also using the latest beta CCC.

Thanks for any help you can provide.

Paul.

More about : 870 7990 cry

August 24, 2013 6:25:07 AM


1. are you using 2 gpu overclocking programs ? e.g msi afterburner and sapphire trixx on same computer if so delete one

2. update your drivers to 13.8 beta 2

3. 7990 is a dual gpu card which means there are 2 7970's working in crossfire and crossfire is known for shuttering in games but 13.8 beta fixes that issue



if nothing works reply back to me
August 24, 2013 8:44:05 AM

Hi. Thanks for your reply. I'm not using any overclocking programs, just CCC. I'm also using 13.8 beta 2. Any help appreciated.

Anurag dcb said:

1. are you using 2 gpu overclocking programs ? e.g msi afterburner and sapphire trixx on same computer if so delete one

2. update your drivers to 13.8 beta 2

3. 7990 is a dual gpu card which means there are 2 7970's working in crossfire and crossfire is known for shuttering in games but 13.8 beta fixes that issue



if nothing works reply back to me


Related resources
August 24, 2013 9:03:33 AM

What resolution are you playing at?
August 24, 2013 1:53:32 PM

jimmy_coma said:
Hi. Thanks for your reply. I'm not using any overclocking programs, just CCC. I'm also using 13.8 beta 2. Any help appreciated.

Anurag dcb said:

1. are you using 2 gpu overclocking programs ? e.g msi afterburner and sapphire trixx on same computer if so delete one

2. update your drivers to 13.8 beta 2

3. 7990 is a dual gpu card which means there are 2 7970's working in crossfire and crossfire is known for shuttering in games but 13.8 beta fixes that issue



if nothing works reply back to me




try downloading msi afterburner

other wise contact the manufacturer or dealer see if they got solution to it
a b 4 Gaming
a c 131 À AMD
a c 539 U Graphics card
August 24, 2013 2:23:33 PM

http://www.hardocp.com/article/2013/08/01/amd_catalyst_...

Quote:
"Out of all the games we played on the Radeon HD 7990, Far Cry 3 was the most inconsistent and choppy. Even with Frame Pacing turned on, it was stuttery feeling, but this lagginess was reduced slightly with Frame Pacing."
August 25, 2013 12:44:24 AM

1920 x 1080. Also, both GPUs are at nearly 100% activity. Could that be right?

freddy1765 said:
What resolution are you playing at?


August 25, 2013 12:48:09 AM

I think 17seconds hit the nail on its head. Far Cry 3 clearly does not perform well with dual GPUs, which seems like the most likely cause of the stuttering you're experiencing. As you say, both GPUs are operating at 100% so clearly they're performing as they should.
I don't know if there's a way to disable one of the two 7970 GPUs on that card, but if there is it would be interesting to run the game with just one of them active and see if it improves.
a b 4 Gaming
a b À AMD
a c 168 U Graphics card
August 25, 2013 4:40:49 AM

Bad new is: FC3 is known to stutter, even on single card configurations the 'net has plenty of articles on it.
I can't keep it dead smooth on the 'high' preset but enabling the ingame Vsync to1 frame and also enabling Vsync in the CCC does improve matters no end (you have to do both BTW) although for fully smooth play I need to drop to the medium preset.
a b 4 Gaming
a c 131 À AMD
a c 539 U Graphics card
August 25, 2013 8:47:18 AM

Your only option is to turn VSync ON and/or use a frame limiter such as that found in the Radeon Pro utility.
August 25, 2013 9:01:52 AM

Thanks for this thread c: I was thinking of getting the 7990, but now I am 100% sure I'm going for the 780
August 25, 2013 9:39:26 AM

Tomb Raider runs like a dream on the highest settings though... Just thought I'd throw that into the mix...
a b 4 Gaming
a b À AMD
a c 168 U Graphics card
August 25, 2013 3:07:20 PM

AH HA!
I think I've found a solution!
After lots of messing around with CCC and ingame settings the answer was this simple: Install RadeonPro and use it to cap the framerate!
The setting is in the 'tweaks' tab, and you have to set it a profile.
You need to have Radeonpro running in the taskbar at least for it to work BTW.
Currently got my i5 750+HD7950 running smoothly at 40FPS on Ultra(no AA though :(  ) you'll be able to set it higher no doubt ;) .
And the framerate cannot drop below the setting, not even a little otherwise the stuttering will return.
a b 4 Gaming
a c 131 À AMD
a c 539 U Graphics card
August 25, 2013 4:52:05 PM

coozie7 said:
AH HA!
I think I've found a solution!
After lots of messing around with CCC and ingame settings the answer was this simple: Install RadeonPro and use it to cap the framerate!
The setting is in the 'tweaks' tab, and you have to set it a profile.
You need to have Radeonpro running in the taskbar at least for it to work BTW.
Currently got my i5 750+HD7950 running smoothly at 40FPS on Ultra(no AA though :(  ) you'll be able to set it higher no doubt ;) .
And the framerate cannot drop below the setting, not even a little otherwise the stuttering will return.


You mean like I suggested about 6 posts up?
a b 4 Gaming
a b À AMD
a c 168 U Graphics card
August 26, 2013 3:47:42 AM

^Er...Yeh...Exactly like that.
a b 4 Gaming
a c 131 À AMD
a c 539 U Graphics card
August 26, 2013 10:45:27 AM

coozie7 said:
^Er...Yeh...Exactly like that.


Well at least you were able to try it out and confirm the steps to get it to work. Sadly, I have not had the pleasure of trying out a Crossfire setup, despite all the great things I have heard about it on these forums. Still, it seems counterintuitive to get a high-end dual-GPU setup and then be forced to limit the FPS in order to get smooth/consistent gameplay, doesn't it?
August 26, 2013 11:50:44 AM

Thanks for all your help everyone. I've been tinkering with the video settings for what feels like an eternity and now have a very smooth FC3. Everything is maxed except the AA which is set to 2. Perhaps it was struggling to apply AA to everything on-screen, and given that the draw distances in the game are pretty big it's possibly understandable.

Anyhow, enjoy yer bank holiday (if you have one).

17seconds said:
coozie7 said:
^Er...Yeh...Exactly like that.


Well at least you were able to try it out and confirm the steps to get it to work. Sadly, I have not had the pleasure of trying out a Crossfire setup, despite all the great things I have heard about it on these forums. Still, it seems counterintuitive to get a high-end dual-GPU setup and then be forced to limit the FPS in order to get smooth/consistent gameplay, doesn't it?


!