Sign-in / Sign-up
Your question

Seagate hard drives not being detected

Tags:
  • Seagate
  • Computers
  • Hard Drives
  • Memory
Last response: in Memory
August 23, 2013 3:34:50 PM

Ive recently built my first computer and was satisfied with the build and everything was working properly. I then had decided to add an optical drive as my father had wanted to for me to rip his cds for better storage and back ups but after installing the optical drive the computer stopped detecting my Seagate hard drive (after a while it also stopped detecting the optical drive but that I know is broken because I tested it on a friends pc). I went out and bought a Samsung SSD and my computer is working fine. The problem that Im having is that Ive RMA'ed the original drive and the replacement drive wont allow the computer to turn on (it flicker for a second and then shuts off), so I then decided to RMA the replacement drive and the new one isnt being detected either (when first installed it the computer flickered just as the original and then I powered on the computer again and this time it booted but the drive was undetected). I would like to know if this is me just having horrible luck or if something is also to blame.

This are my computer specs:
Intel 4670K- dont think this has anything to do with the problem but it is connected to the mother board so I guess it helps to know
Patriot Viper III 16GB- again dont think this has anything to do with the problem but it is connected to the mother board so I guess it helps to know
Asus z87 pro motherbaord
Corsair AX760 platinum power supply
Samsung 840 Pro 128GB SSD-this is what I currently using and will remain being my boot drive
Corsair H100i-dont think this has to do with the problem but its connected to the power supply via a separate sata power cable than my other storage drives, but was originally connected to the same one when the original hard drive was working
Seagate Barracuda 2TB drive- model number ST2000DM001- this is what I think the problem is

Trouble Shooting Steps done:
-Restarted Computer
-Loaded Optimized( its pretty much the default settings my motherbaord came with) Bios profile
-Plugged in SSD into the same exact sata power port and sata motherboard port that the Seagate drive was not working in and the SSD to worked just fine.
- Change the sata port, sata data cable and sata power cable
-RMA the Seagate drives twice so Ive effectively tried 3 different drives.
-Ran Seatools for Windows (program that Seagate recommends to use to trouble shot drives) and it did not detect the drive

More about : seagate hard drives detected

January 8, 2014 12:06:03 PM

I am currently having the same problem. My 1TB seagate hdd is not being detected in the bios and windows 8.1 won't get past the load screen.

I7-4770k
16gb g skil 1866
Asus z-87-a
Seasonic 550w
Msi gtx 770
Samsung 840 evo 120gb ssd

I haven't RMA'd the drive yet...but I wanted to at least see if anyone else was having a problem and this matches up pretty closely.

We are both using z-87 asus's and the bios is not detecting anything...so I'm inclined to think it has something to do with the mobo...