Sign in with
Sign up | Sign in
Your question

M5A97 R2.0 front USB 3.0 ports not working

Last response: in Motherboards
Share
September 17, 2013 5:02:19 PM

Hi, I have the M5A97 R2.0 motherboard and had a fresh install of Windows 7 with the Corsair 300R case. I have already connected a plug from the case that looked like it was for the USB 3.0 to the motherboard. It fitted perfectly to the pins labeled USB 3.0 on the motherboard.

However, when I plugged in my USB 3.0 thumb drive it didn't detect it on the front panels, so I tried the rear, but none of them worked. I checked the Device Manager and realized that I had to install the USB 3.0 drivers. After I installed the USB 3.0 drivers from the ASUS website, the rear USB 3.0 ports worked, but the front USB 3.0 ports still did not respond.

I noticed that there were only two unknown devices/unknown usb controllers listed in the Device Manager when it didn't work at the time so I guess that means the front USB panels was never detected.

Is it a problem with the computer case or is there a BIOS setting that needs to be changed to get it to work? I checked and under USB Configuration everything is listed as Enabled. I would hate to believe that the USB 3.0 wire on the case doesn't work. That was one of the reasons I bought the case.

Does anyone know how to fix it or have any idea what the problem could be?
a c 331 V Motherboard
September 17, 2013 7:11:52 PM

If you installed the USB 3.0 driver and the back ports work, the front ports should also work as long as you have the FP USB 3.0 cable firmly inserted in the USB 3.0 MB header. Do you have a USB3 to USB2 adapter so you can try the ports on the USB 2.0 MB headers? Some case's come with one. I don't think the 300r does, however.
September 17, 2013 10:45:42 PM

I just reseated the cable. Apparently, it was loose. It works now. Thanks for replying.
!