Asus Z87-k: bios update error "this is no uefi file"

Actually it's two problems the first causing the second.

On first boot my SSD is not recognized, thus the OS cant be found and booted. reboot does not help after a certain time has passed. (3 reboots dont help as long as at least 15 seconds have passed, then just one will do). Any suggestions?

So i thought i may update the bios firmware, cause the issue might be solved then. turns out i can't update the bios. i downloaded the latest firmware 0706 for my z87-k of course. the EZ-flash tool within the bios then tells me: "the selected file is no uefi bios" and aborts update.

thanks for your help in advance
10 answers Last reply
More about asus z87 bios update error uefi file
  1. Is the SSD connected to a SATA 3 cable? Have you tried different SATA port?
    Regarding the BIOS: Using a FAT formatted USB stick? Have you unzipped the file? And using an USB 2.0 port?
  2. thanks for the answer. i will try the cable thing tomorrow.

    the stick is fat formatted, file is (of course) unzipped and the port is even 3.0.

    u gotta think a little more intense for that i hope ;)
  3. Intense? Not for me. Try a USB 2.0 port for updating the BIOS.
  4. tried differents ports and different usb sticks, still "selected file is not a UEFI bios"
  5. Have you tried using the renamer in BIOS Utilities (although not specified in the manual)?
    http://www.asus.com/Motherboards/Z87K/#support_Download_29
  6. no, but i just discovered another button on my mouse which opened a completely hidden menue in windows 7! it offered me to rename it myself.
  7. OK, do you know the name?
  8. well renamed it, and just in case the "renamer" changes the header of the file or something i tried that aswell. still same error
  9. What about the SATA cable? Still the same?
  10. did you make sure it isnt in any folders? As far as file name, for my asus sabertooth needed the bios file to be a .cap file
Ask a new question