Sign in with
Sign up | Sign in
Your question

Win7, failing to get access to router/Internet on 1 PC

Last response: in Networking
Share
September 30, 2013 1:42:43 PM

Hi, I can't seem to get an Internet connection (or a connection to my router for that matter) on my PC.
I assume it's not a router issue, because I can access it with my laptop through WLAN and LAN, with the same cable I'm using on my pc, so no cable issue either. The network has 2 other laptops accessing through WLAN and a PC through LAN as well. I doubt it's an ethernet card issue as well, because I can access a different router with the same PC without any trouble.

The automatically assigned IP adress is 169.254.128.59 right now with a 255.255.0.0 subnet mask, although the router range is 192.168.2.100-199. I tried assigning an IP in that range with a 255.255.255.0 subnet mask to no avail. Pinging the router failed as well. Tried to turn off TCP/IP v6 because I read somewhere that that might solve some problems, but it changed absolutely nothing either.

At some point I assumed the issue might be due to the connection being recognized as a public network, so after a lot of searching, the only method I found to change it to a home network was this: http://support.microsoft.com/kb/2578723#LetMeFixItMyselfAlways, which changed the connection from unidentified public network to unidentified home network...yet still with the same issues.

I also turned off all AVG services and Windows firewall, deactivated and uninstalled the network card, restarted the router (DHCP Server is enabled on the router by the way) and switched out the LAN cable, although the first one worked on my laptop anyway.

Usually I'm able to fix seemingly small problems like this with the help of google, but I have spent hours reading through threads about similar issues without getting anywhere and at this point I'm just completely out of ideas and I'm not even sure where my problem lies.

Any insight on this would be appreciated.
Thanks in advance.
November 19, 2013 8:04:41 PM

Hi, I also have the same issue. Were you able to resolve it? (I hope so!).

Thanks
...
November 19, 2013 8:36:56 PM

The 169.x.x.x IP is a default given to a NIC that has no connection. On the NIC adapter properties, under Ipv4, is it specified to obtain IP address and DNS automatically? Does adapter icon in lower right of screen show "network cable unplugged'? You're sure your cable is plugged into one of ports 1-4 on the router and not another port (like WAN)?
!