Sign-in / Sign-up
Your question

Issue with getting a display from my graphics card

Tags:
  • Graphics Cards
  • Monitors
  • Graphics
Last response: in Displays
October 3, 2013 8:36:06 AM

Hello.

My Specs:

Windows 8 64 Bit (Had the same issue on W7)
Graphics: NVIDIA GTX 670 PCIE
Processor: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
Motherboard: ASUSTeK COMPUTER INC. P8Z77-V
BIOS: 2104 (Up tp date)
RAM: 8GB
Monitor: ACER S240HL

After spending the past week trying to solve an issues, I sent my PC to a computer shop to be looked at, but it seems all the hardware is fine with no issues. However, when I'm trying to connect my graphics card's HDMI port to my Acer S240HL monitor, I just cannot get a display. While, it displays perfectly fine on my Toshiba HD TV. I have formatted my OS (Windows 7) without any luck, so I decided to use a spare Windows 8 key laying around. I have updated my main drivers and windows update has updated everything at the current time.

I can confirm that the monitor is not broken, because it worked with my older computer pefectly fine. Also, when I have often managed to get a display on it when running in safe mode on W7, as well as (before I installed nvidia drivers) when I booted on the TV and swapped the cable to the monitor.

In the past the monitor has always only displayed at the welcome screen when using the graphics card, but thats never really caused any issues. Like stated above, all hardware has been checked and fully functional, so it must be some sort of software issues. I also did install the monitor drivers when I was running W7 without luck (They dont seem to work with W8).

In summary:

I cannot got a display with my Acer S240HL Monitor using my graphics card, but my Toshiba HDTV displays (as well as a computer shop testing all my hardware). The Acer monitor works on other computers and I managed to run in W7 safe mode, but recently upgraded to W8.

I've been struggling with this issue for way too long. Any help would be appreciated.

More about : issue display graphics card

Anonymous
a b U Graphics card
October 3, 2013 9:03:52 AM

Did you try to connect other interfaces like dvi or vga?
m
0
l
a b U Graphics card
a b C Monitor
October 3, 2013 9:06:24 AM

Did you reinstall the acer driver?
m
0
l
Related resources
October 3, 2013 9:24:17 AM

Anonymous said:
Did you try to connect other interfaces like dvi or vga?


The graphics card doesn't have a VGA slot, and I don't have a DVI cable laying around. Though that is an option if nothing else works.

"Did you reinstall the acer driver?"

It doesn't seem to be compatible with Windows 8
m
0
l
October 3, 2013 10:13:36 AM

So, I managed install the acer monitor drivers by disabling Microsoft's digital thingy, but it didn't help at all.

I also tried running Safe Mode again, and the monitor works fine there.

What do?
m
0
l
a b U Graphics card
a b C Monitor
October 4, 2013 4:28:14 AM

Yeah I saw on the site that they don't have a W8 driver, but I was hoping the W7 driver might get the job done. Back to W7 methinks.
m
0
l