"Safely Remove Hardware" systray icon missing. (Hot Swap inop)

When I completed this fresh build about 8 months ago BIOS was configured for AHCI and Hot Swap was enabled for the two mobile rack bays. From the start all worked properly; Any time I installed a drive into the mobile racks or plugged in a USB device the Windows device manager in the systray would pop up allowing for a proper dismount when required. About two months ago Intel Rapid Storage Technology (which I originally installed with OS) prompted for an upgrade but in my wisdom decided to simply remove the utility as many reviews say it serves no purpose. Unfortunately after removal of Intel RST no longer will the systray device manager pop up or display drives mounted into the bays although It does work properly for all devices plugged into USB ports.

I have since reinstalled IRST but the problem persists. Checking BIOS -- AHCI and hot swapping of individual drives remain enabled. I also placed on the desktop the following shortcut "%windir%\system32\RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll" which allows me to manually open the Windows USB/Hotswap manager. Even with drives mounted in both of the HS bays the manager does not display either whereas it did prior to me removing IRST. Lastly, as suggested by someone else, I ran an sfc scan in "verifyonly" mode and it found no integrity violations.

Any insight much appreciated.

Windows 7 64
P8Z77-V LK
5 answers Last reply
More about safely remove hardware systray icon missing hot swap inop
  1. You could go to a restore point from before you uninstalled it.
  2. Thanks for the reply!

    I was going to use your advice even though my sole restore point looked to be May 01 and would effect many programs installed since then (including a boatload of Windows updates). Unfortunately when attempting to activate the restore point it advised it could not locate the file. A little investigation shows I do have sys restore ON for that drive but for some inexplicable reason size allocation was set to 0! Guess the multitude of restore points I've made with every app installation and or major change since day one has been for naught. Have to continue researching out and hope for another solution.
  3. Goto Computer and then, (Right Click the Drive) > Eject
    It's an alternative, but you can do something else.
  4. ScottB1234 said:
    Goto Computer and then, (Right Click the Drive) > Eject

    Thanks for the reply!

    I have no "Eject" option on right-click context menu. Did double check in BIOS to make sure hot swap was enabled for all data drive SATA ports. I remain on the quest to solve this elusive missing link.
  5. Ok, not wholly "solved" but I did decide to install the HotSwap! utility for a very seamless and even more feature rich work-around. Functions a charm just as it did when last used with XP.
Ask a new question

Read More

Windows 7