Sign in with
Sign up | Sign in
Your question

Asus g74sx laptop not working.

Last response: in Motherboards
Share
January 26, 2014 9:13:40 PM

Hi,

I have an asus g74sx and it does not turn on. When the power supply is in, no lights turn on, no charger light, no power light etc.

The only thing that happens is as soon as the power supply touches the PSU the battery charging light flashes red once and doesn't flash again until I take the power supply out. Put the power supply in again, the light flashes red again (just one flash).
Here is a video of the light flashing red. You can't see me putting the power supply in and out, but every time you see the red light flash in this video, I am either putting the power supply in or out.
https://www.dropbox.com/s/4z7jxzipm3wufuf/MOV_8841.mp4

This is what I have tried thus far.
-Since my brother has the exact same laptop, we used his HDD, ram, charger, battery and power supply in place of mine, however none of that worked.
-We also took the battery out and held the power button down to try and discharge any build up in the motherboard. Didn't work.
- We took the laptop apart. We used the part which contains the power button, keyboard and touch pad, we tested that in my brother laptop, works fine.
- Next we tested voltages across all transistors and the PSU aswell (in the motherboard). We compared my laptop readings with his readings. We got he same readings.

Does anyone have any idea of what is happening?
Thank you for any help.
a b V Motherboard
January 27, 2014 5:38:30 AM

Hmm, I think your mobo is gone, RIP.
You have some power issues. Probably some component IC, is dead. Which one I can't tell. Probably one that checks is there input voltage and than do something. Probably is 4,6 or 8 pin IC. Finding that is like find needle in haystack. If you can take it to service for repair, if they can.
Good luck.
February 19, 2014 1:39:08 PM

legendxwarrior said:
Hi,

I have an asus g74sx and it does not turn on. When the power supply is in, no lights turn on, no charger light, no power light etc.

The only thing that happens is as soon as the power supply touches the PSU the battery charging light flashes red once and doesn't flash again until I take the power supply out. Put the power supply in again, the light flashes red again (just one flash).
Here is a video of the light flashing red. You can't see me putting the power supply in and out, but every time you see the red light flash in this video, I am either putting the power supply in or out.
https://www.dropbox.com/s/4z7jxzipm3wufuf/MOV_8841.mp4

This is what I have tried thus far.
-Since my brother has the exact same laptop, we used his HDD, ram, charger, battery and power supply in place of mine, however none of that worked.
-We also took the battery out and held the power button down to try and discharge any build up in the motherboard. Didn't work.
- We took the laptop apart. We used the part which contains the power button, keyboard and touch pad, we tested that in my brother laptop, works fine.
- Next we tested voltages across all transistors and the PSU aswell (in the motherboard). We compared my laptop readings with his readings. We got he same readings.

Does anyone have any idea of what is happening?
Thank you for any help.


!