Sign in with
Sign up | Sign in
Your question

Sata recognized under USB not Sata or esata

  • SATA
  • Storage
  • USB
  • Hard Drives
  • Seagate
Last response: in Storage
April 2, 2014 3:33:18 PM

I have a Seagate 1.5TB HDD. Model ST1500DM003. I'm using Win8.1 on a ASRock Z77 board. It stopped being detected as sata on my PC.
I unplugged it and tried it as esata. It seemed to partially recognize it but wouldn't read the data. I thought it was either controller card issues or driver issues. I reinstalled the drivers but didn't work.
I tried it via USB (Thermaltake BlacX Sata to USB/esata mount) and it worked detected and is good to go.
I tried it as esata - locks up my PC. I tried it as Sata - won't detected.
I tried it via USB on my Win7 laptop - no issues. esata won't detect at all on that either.

I'm perplexed. Any thoughts? I looked for firmware - none available. Drive is 1.5 year old.

More about : sata recognized usb sata esata

a c 971 G Storage
April 7, 2014 6:47:45 PM

Sounds like some configuration data has corrupted; good thing its still under warranty.