Help With Com Ports!

Hi there! I have a X401U Asus Notebook here. It has two usb ports, one is a 2.0 and the other is a 3.0. I am having a problem lateley connecting devices to my computer.

My computer is already one year old. Last time, I still get to connect usb devices such as webcams, celpphones, thum drives, keypads, mouse etc. easily. The drivers install automatically.

Recently I plugged in my newly bought Canon EOS. I installed the software which came with it. The camera won't install properly. I needed it to get connected via usb cause I am getting live feed from it. (I work on stop motion so please don't suggest me buying a card reader)

Next I bought a new Xbox 360 controller, and when I connected it, it won't also install correctly even if I tried installing the software for it. (i tried the camera and controller in both usb ports and none worked)

So I made some research. I discovered that the cause may be the com ports. I had used a lot of usb devices on my laptop. That's why I thought of cleaning up/resetting/deleting all the com ports assigned. (it would be ok if I need to install again eveything) (what's important is I get to connect the camera and the controller cause they are priority.

What I did is I went to device manager, I selected the option of "Show hidden devices" and found out that there wasn't any "Ports" tab in Device Manager. I need to delete those com ports but I don't have any idea what else to do. What must I do? Thankss much! I've been looking for a solution for this more than one month. Please help me cause I need the camera as soon as possible. :(((
1 answer Last reply
More about ports
  1. Com ports are a red herring. Most modern laptops don't have any com ports. Hae you installed the EOS utility as well as the USB driver? Have a look at this thread: http://photo.stackexchange.com/questions/34703/cant-connect-canon-6d-to-my-computer-via-usb-cable
Ask a new question

Read More

com port missing USB ports lpt missing Apps Xbox eos Device Manager ports missing Asus com ports com ports