Solved

Keyboard isn't working in Windows 10.

So I installed Windows 10 and my keyboard has been rendered useless. I chose to jump the queue as it were (rather than wait for the on-screen notification) - not sure if that's relevant.

The keyboard is made my a Chinese company called E-Elements. It's a mechanical keyboard with RGB lighting (this one: https://www.massdrop.com/buy/e-element-rgb-keyboard ... http://www.amazon.co.uk/607/dp/B00UJ8XSTI/ref=sr_1_2/276-4723395-9230301?ie=UTF8&qid=1438364208&sr=8-2&keywords=e-element+rgb+keyboard).

The RGB lighting works perfectly fine (but then it would because it's just being powered via USB) - the problem is that none of the keys are working. The NUM LOCK and CAPS LOCK LED indicator also isn't working. I tried a different keyboard (non-mechanical) and that works fine, so thought the keyboard itself was the issue. I then plugged it into my PS4 and it works fine. I then booted my PC in BIOS and weirdly it also works fine in BIOS, so it's definitely an issue with the keyboard communicating with W10 or W10 communicating with the keyboard.

Another thing I should probably mention is that when I installed W10, I didn't do a clean install, I chose to keep my files and settings. I have since, however, reinstalled W10 as a clean install as I had backed everything up anyway - it still didn't work.

Somebody suggested simply reverting back to W7, but I have now lost that option since I have reinstalled W10 a second time.

I have also checked Device Manager for any USB devices with an exclamation mark, and reinstalled several drivers. Weirdly, the device manager does actually recognise it as a keyboard.

I am almost at a total loss as I feel like I've tried everything. I really like this keyboard and don't fancy swapping it out for a different one.
4 answers Last reply Best Answer
More about keyboard working windows
  1. Hi
    Is your keyboard in USB 2 or USB 3 port

    It should be in USB 2 port

    Have you installed the motherboard chipset drivers assuming there are win 10 drivers available

    Does this keyboard require a special keyboard driver ?

    Regards
    Mike Barnes
  2. Hi, yes it's plugged into USB2.0.
    It doesn;t require any special drivers, just generic keyboard driver.

    My motherboard is a Asrock z77 Extreme4. Since I chose not to do a clean install (as in, I chose to keep all my files and settings) I was under the assumption I wouldn't have to reinstall drivers. If that's wrong, then I'll try that next, and hopefully it'll work.
  3. Sorry for double post, but would somebody be able to point me in the right direction for the chipset driver for my mobo? (ASrock Extreme4 z77) as one for W10 doesn't seem to exist. Should I try installing w8.1 drivers and see if that makes a difference? I'm at the end of my sanity here, and have no idea what's going on.
  4. Best answer
    I dealt with this problem and found that Windows 10 was just using the wrong USB driver. Go to the device manager and look at your USB Controllers. There will likely be an item in there called the "N-Tech USB Adapter". This is your keyboard. Go to that items properties and select "update driver". Manually select your driver and look at the list of existing drivers. For me there were only two drivers. The one that is currently selected is incorrect! Just pick the other one. Worked like a charm after that.
Ask a new question

Read More

windows 10 Keyboards