Windows 10 Display issues - blank screen with no mouse after boot. No windows logo during boot.

Hi,

I had updated to windows 10 couple of days ago. Windows 10 usually does all the updates on its own, and I think that's where one of the problem is. Turned the system off last night, today I turn it on but all I get is the boot screen showing for 30 seconds, and then a blank screen follows. The sound still works, indicating the system started up. My PC runs windows 10 pro, but it has a built in CPU and an add on graphics card (the big one) - Nvidia Geforce GTX 660. Also, most people have reported that the cursor is present on thr blank screen. It isn't in my issue. Its just boot screen for 30+ seconds and then blank screen.
4 answers Last reply
More about windows display issues blank screen mouse boot windows logo boot
  1. windows 10 has a driver issue that they have not worked out. it been over writing good drivers and hosing systems. plug your monitor into onboard video port see if there video there. if it is remove the old gpu drivers and make sure you have the newest windows 10 drivers from nvidia. if there no onboard video then try forcing windows 10 into safe mode to remove the old gpu drivers.
  2. smorizio said:
    windows 10 has a driver issue that they have not worked out. it been over writing good drivers and hosing systems. plug your monitor into onboard video port see if there video there. if it is remove the old gpu drivers and make sure you have the newest windows 10 drivers from nvidia. if there no onboard video then try forcing windows 10 into safe mode to remove the old gpu drivers.


    Hi

    I tried plugging it into the onboard video port but no signal was sent through to it. I forcefully shut down the system several times and then plugged it back to the main graphics card, and all of a sudden, it works. I'm afraid the same problem may occur again.
  3. I have exactly the same problem, with no external graphics card on a fresh install. Basically everything works until the login screen, then there is nothing. No mouse, nada. But safe mode works.
  4. i am having same issue . black screen no cursor, get logo but no chance to login. i am not using my gpu,s . i want to resove issues before installing since i have water cooling ,in sli. i do get windows in safe mode , is there a solution
    thanks
Ask a new question

Read More

windows 10 Boot