BAD POOL HEADER 0x00000019 tcpip.sys

Good evening!
I would like your help!
Suddenly today with win10 I got blue screen (3 times) with the following:
BAD_POOL_HEADER 0x00000019
caused by driver: tcpip.sys
caused by address: tcpip.sys + 810c1
crash address: ntoskrnl.exe + 14e240

I quote the dump file:
https://copy.com/zqAAJFxJOYGuwfUd

Thanks in advance!
14 answers Last reply
More about bad pool header 0x00000019 tcpip sys
  1. Try updating or reinstalling your network adapter drivers. What is your motherboard model number?
  2. darkbreeze said:
    Try updating or reinstalling your network adapter drivers. What is your motherboard model number?


    motherboard: asus maximus formula II
    USB WIFI: Crypto 150 s2

    I will make try to reinstall the network drivers
  3. Did you force the update to Windows 10? That motherboard doesn't even have any ASUS supplied Windows 8 drivers on it's product page, much less Windows 10. And I'm not seeing the drivers for the Wireless adapter you listed either. If you can find Windows 10 specific drivers for the Crypto 150 S2, that would be a good place to start.
  4. darkbreeze said:
    Did you force the update to Windows 10? That motherboard doesn't even have any ASUS supplied Windows 8 drivers on it's product page, much less Windows 10. And I'm not seeing the drivers for the Wireless adapter you listed either. If you can find Windows 10 specific drivers for the Crypto 150 S2, that would be a good place to start.


    unfortunately there is nothing specific about the wireless adapter for, 10,
    I try a different adapter and see!

    But so far I have done the following:
    - Force check for windows update
    - Motherboard update check
    - Bios check for last update
    - Drivers check for last updates
    - memtest
    - Chkdisk / f
    - Reg clean / repair
    - Malware search
    - Unistall avast with avast tool
    - Reinstall wireless adapter (the one who has 10 preloaded)
    - Disable the ethernet
    - Reinstall nvidia drivers
    - Now I will do a defrag

    And see!

    You think the problem is the wirless?
  5. i would also remove:
    F:\epifania ergasias\RealTemp_370\WinRing0x64.sys Sat Jul 26 06:29:37 2008
    not sure what this driver is:xlkfs.sys Fri May 04 20:47:12 2012

    looks like you have the current bios version


    ---------------
    looks like you have a usb wireless adapter.very common for old bios to have bugs in its BIOS USB support.
    I would start with a BIOS update (if there is one).
    look ;here:https://www.asus.com/ROG-Republic-Of-Gamers/MAXIMUS_II_FORMULA/HelpDesk/
    (website not respondingfor me right now)

    BIOS Release Date 04/15/2010
    BIOS Version 2302
    Manufacturer ASUSTeK Computer INC.
    Product Maximus II Formula
    Processor Manufacturer Intel
    Processor ID 7a060100fffbebbf
    Processor Version Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz
    Processor Voltage 8bh - 1.1V
    External Clock 333MHz
    Max Speed 3800MHz
    Current Speed 2833MHz
  6. johnbl said:
    i would also remove:
    F:\epifania ergasias\RealTemp_370\WinRing0x64.sys Sat Jul 26 06:29:37 2008
    not sure what this driver is:xlkfs.sys Fri May 04 20:47:12 2012

    looks like you have the current bios version


    ---------------
    looks like you have a usb wireless adapter.very common for old bios to have bugs in its BIOS USB support.
    I would start with a BIOS update (if there is one).
    look ;here:https://www.asus.com/ROG-Republic-Of-Gamers/MAXIMUS_II_FORMULA/HelpDesk/
    (website not respondingfor me right now)

    BIOS Release Date 04/15/2010
    BIOS Version 2302
    Manufacturer ASUSTeK Computer INC.
    Product Maximus II Formula
    Processor Manufacturer Intel
    Processor ID 7a060100fffbebbf
    Processor Version Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz
    Processor Voltage 8bh - 1.1V
    External Clock 333MHz
    Max Speed 3800MHz
    Current Speed 2833MHz


    I have the latest bios, I erased both files (xlkfs.sys is part of Easy File Locker prog).I will now try a abapter of gigabyte and see if something changed!
  7. Winring0x64 tend to corrupt kernel data stored in memory.


    scoobyman said:
    johnbl said:
    i would also remove:
    F:\epifania ergasias\RealTemp_370\WinRing0x64.sys Sat Jul 26 06:29:37 2008
    not sure what this driver is:xlkfs.sys Fri May 04 20:47:12 2012

    looks like you have the current bios version


    ---------------
    looks like you have a usb wireless adapter.very common for old bios to have bugs in its BIOS USB support.
    I would start with a BIOS update (if there is one).
    look ;here:https://www.asus.com/ROG-Republic-Of-Gamers/MAXIMUS_II_FORMULA/HelpDesk/
    (website not respondingfor me right now)

    BIOS Release Date 04/15/2010
    BIOS Version 2302
    Manufacturer ASUSTeK Computer INC.
    Product Maximus II Formula
    Processor Manufacturer Intel
    Processor ID 7a060100fffbebbf
    Processor Version Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz
    Processor Voltage 8bh - 1.1V
    External Clock 333MHz
    Max Speed 3800MHz
    Current Speed 2833MHz


    I have the latest bios, I erased both files (xlkfs.sys is part of Easy File Locker prog).I will now try a abapter of gigabyte and see if something changed!
  8. johnbl said:
    Winring0x64 tend to corrupt kernel data stored in memory.


    scoobyman said:
    johnbl said:
    i would also remove:
    F:\epifania ergasias\RealTemp_370\WinRing0x64.sys Sat Jul 26 06:29:37 2008
    not sure what this driver is:xlkfs.sys Fri May 04 20:47:12 2012

    looks like you have the current bios version


    ---------------
    looks like you have a usb wireless adapter.very common for old bios to have bugs in its BIOS USB support.
    I would start with a BIOS update (if there is one).
    look ;here:https://www.asus.com/ROG-Republic-Of-Gamers/MAXIMUS_II_FORMULA/HelpDesk/
    (website not respondingfor me right now)

    BIOS Release Date 04/15/2010
    BIOS Version 2302
    Manufacturer ASUSTeK Computer INC.
    Product Maximus II Formula
    Processor Manufacturer Intel
    Processor ID 7a060100fffbebbf
    Processor Version Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz
    Processor Voltage 8bh - 1.1V
    External Clock 333MHz
    Max Speed 3800MHz
    Current Speed 2833MHz


    I have the latest bios, I erased both files (xlkfs.sys is part of Easy File Locker prog).I will now try a abapter of gigabyte and see if something changed!




    Unfortunately, whatever I tried of them nothing happened, it continues to have occasional BSOD
  9. if you continue to have pool corruption after you have removed the suspect drivers, then make sure you
    update the BIOS or reset it to defaults and that memtest86 runs without failures.

    it it passes, you would want to change the memory dump type from a minidump to a kernel memory dump and then start cmd.exe as an admin and run
    verifier.exe /standard /all
    and reboot your machine, when you get the next bughceck put the c:\windows\memory.dmp file on a server and post a link.

    note: use verifier.exe /reset to turn off verification of your drivers.

    scoobyman said:
    johnbl said:
    Winring0x64 tend to corrupt kernel data stored in memory.


    scoobyman said:
    johnbl said:
    i would also remove:
    F:\epifania ergasias\RealTemp_370\WinRing0x64.sys Sat Jul 26 06:29:37 2008
    not sure what this driver is:xlkfs.sys Fri May 04 20:47:12 2012

    looks like you have the current bios version


    ---------------
    looks like you have a usb wireless adapter.very common for old bios to have bugs in its BIOS USB support.
    I would start with a BIOS update (if there is one).
    look ;here:https://www.asus.com/ROG-Republic-Of-Gamers/MAXIMUS_II_FORMULA/HelpDesk/
    (website not respondingfor me right now)

    BIOS Release Date 04/15/2010
    BIOS Version 2302
    Manufacturer ASUSTeK Computer INC.
    Product Maximus II Formula
    Processor Manufacturer Intel
    Processor ID 7a060100fffbebbf
    Processor Version Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz
    Processor Voltage 8bh - 1.1V
    External Clock 333MHz
    Max Speed 3800MHz
    Current Speed 2833MHz


    I have the latest bios, I erased both files (xlkfs.sys is part of Easy File Locker prog).I will now try a abapter of gigabyte and see if something changed!




    Unfortunately, whatever I tried of them nothing happened, it continues to have occasional BSOD
  10. After that I can't boot up getting a error message https://mega.nz/#F!esMh3a6b!va74BOz9559h6i_AgmoD8g
  11. if you have verify turned on and on reboot it finds a bad device driver it calls a bugcheck and shuts down the system.
    The memory dump will contain the info on the bad driver.

    if your system bugchecks during startup you have to boot into safe mode (f8 or shift+f8) and turn off the verification
    verifier.exe /reset

    then reboot again.

    you could also go to a restore point.


    scoobyman said:
    After that I can't boot up getting a error message https://mega.nz/#F!esMh3a6b!va74BOz9559h6i_AgmoD8g
  12. johnbl said:
    if you have verify turned on and on reboot it finds a bad device driver it calls a bugcheck and shuts down the system.
    The memory dump will contain the info on the bad driver.

    if your system bugchecks during startup you have to boot into safe mode (f8 or shift+f8) and turn off the verification
    verifier.exe /reset

    then reboot again.

    you could also go to a restore point.


    scoobyman said:
    After that I can't boot up getting a error message https://mega.nz/#F!esMh3a6b!va74BOz9559h6i_AgmoD8g





    My friend, in the end, I could not go into safe mode (I did not know that win 10 have disabled F8) did from elsewhere a boot recovery disk, but not the return to the previous point made, neither repair the start, so I had to make recover with acronis backup from the last win 7 I had and then again win 10!

    Anyway, thank you all for your time and your help!
  13. windows should not have disabled f8 or shift+ F8, sometimes a BIOS will have fast boot enabled that makes a very short timing windows to get into safe mode. (you have to get into bios and disable the fast boot)

    scoobyman said:
    johnbl said:
    if you have verify turned on and on reboot it finds a bad device driver it calls a bugcheck and shuts down the system.
    The memory dump will contain the info on the bad driver.

    if your system bugchecks during startup you have to boot into safe mode (f8 or shift+f8) and turn off the verification
    verifier.exe /reset

    then reboot again.

    you could also go to a restore point.


    scoobyman said:
    After that I can't boot up getting a error message https://mega.nz/#F!esMh3a6b!va74BOz9559h6i_AgmoD8g





    My friend, in the end, I could not go into safe mode (I did not know that win 10 have disabled F8) did from elsewhere a boot recovery disk, but not the return to the previous point made, neither repair the start, so I had to make recover with acronis backup from the last win 7 I had and then again win 10!

    Anyway, thank you all for your time and your help!
  14. scoobyman said:
    johnbl said:
    i would also remove:
    F:\epifania ergasias\RealTemp_370\WinRing0x64.sys Sat Jul 26 06:29:37 2008
    not sure what this driver is:xlkfs.sys Fri May 04 20:47:12 2012

    looks like you have the current bios version


    ---------------
    looks like you have a usb wireless adapter.very common for old bios to have bugs in its BIOS USB support.
    I would start with a BIOS update (if there is one).
    look ;here:https://www.asus.com/ROG-Republic-Of-Gamers/MAXIMUS_II_FORMULA/HelpDesk/
    (website not respondingfor me right now)

    BIOS Release Date 04/15/2010
    BIOS Version 2302
    Manufacturer ASUSTeK Computer INC.
    Product Maximus II Formula
    Processor Manufacturer Intel
    Processor ID 7a060100fffbebbf
    Processor Version Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz
    Processor Voltage 8bh - 1.1V
    External Clock 333MHz
    Max Speed 3800MHz
    Current Speed 2833MHz


    I have the latest bios, I erased both files (xlkfs.sys is part of Easy File Locker prog).I will now try a abapter of gigabyte and see if something changed!



    Seriously - try downgrading to BIOS 2202 from 2302. Its much more stable. I have been running Maxiums Forulma since 2009 with q9550 @3.92ghz and DDR at 1105mhz (base 1066mhz) since then. Also Windows 10 since June.
    I only updated to BIOS 2302 two days ago and get this error now every hour or so! Never before on 2202. I'm going to downgrade myself.

    How to:

    Go into BIOS and save your bios setting profile to profile 1 or 2 or both. Also flash BIOS to other BIOS if you want (so you can still boot your current BIOS from the 2nd BIOS if it goes wrong or you want to go back to 2302 again)

    https://www.asus.com/Motherboards/MAXIMUS_II_FORMULA/HelpDesk_Download/

    Download Maximus II Formula 2202 BIOS

    Download ASUS Update V7.17.06 Install Program for Windows XP/Vista/7 32bit & 64bit and install.

    Run asus update and selec options and select "allow downgrade" option.

    Then select upgrade bios from file. Find rom - flash and reboot.

    Go into BIOs and reload profile - so you don't have set all the settings again. :)
Ask a new question

Read More

windows 10 Blue Screen TCP/IP Ntoskrnl.Exe