Sound doesn't work after NVIDIA update (Windows 10)

Hiya,

After updating my NVIDIA driver (GeForce 9500 GT) I can't hear any sound coming from my computer. It's hooked up to a couple of speakers, I tried them on my laptop and they work. I also tried my headphones, they don't work either.

When looking at my playback devices I can only see Digital Audio (S/PDIF) which looks like it's working just fine. I tried updating the driver but it says it's been fully updated.
I reinstalled the NVIDIA driver but that doesn't work either.

Specs:
Processor: Intel(R) Pentium(R) D CPU 3.40 GHz 3.41 GHz
Installed memory: 4,00 GB (3,00 GB usable)
System type: 32-bit Operating System, x64-based processor

I installed Windows 10 quite recently as well.

Could anyone please help me fix it?
6 answers Last reply
More about sound work nvidia update windows
  1. In Playback Devices, right click on empty space and select "Show disabled devices." See if your Speakers or Headphones are among them. Enable them and set them as defaults if they are.
  2. Slashgeek said:
    In Playback Devices, right click on empty space and select "Show disabled devices." See if your Speakers or Headphones are among them. Enable them and set them as defaults if they are.


    They aren't unfortunately, the Digital Audio is the only device there...
  3. What I would recommend is doing a fresh install of the driver...check advanced> clean install, then UNCHECK everything EXCEPT the driver (its auto picked -grayed out) and the Physx driver -uncheck the hdmi/audio/3d drivers and geforce experience.. This is how I got mine to work. Its an issue with the nvidia audio drivers I had the same issues a couple driver updates ago -then I learned that trick- as i use external speakers (as you do) and I dont have a 3d monitor or care about gefore experience mucking my games up :|

    Try that and

    reboot,

    try the audio again!

    Hope this helps
  4. Try performing a System Restore operation to the time when things were working properly. If things work correctly this time, install the 9500 GT driver again, but this time uncheck "HDMI Audio driver" in the list of things to install.
  5. Hi guys,

    Sorry it has taken me this long to reply, I tried both your ideas, unfortunately they didn't work. In the end I figured I could just use the Digital Audio. What I did was get a special cable to process digital sound, then connect this cable to a convertor (I had to order these so that's why it took so long for me to respond) and the convertor to analog sound. So in the end I didn't really resolve the issue but worked my way around it. In any way, thanks for your advice!
  6. hi, I am having similiar problems, can you tell me where I would rind the advanced bit you talk of below? Many thanks.

    NerdIT said:
    What I would recommend is doing a fresh install of the driver...check advanced> clean install, then UNCHECK everything EXCEPT the driver (its auto picked -grayed out) and the Physx driver -uncheck the hdmi/audio/3d drivers and geforce experience.. This is how I got mine to work. Its an issue with the nvidia audio drivers I had the same issues a couple driver updates ago -then I learned that trick- as i use external speakers (as you do) and I dont have a 3d monitor or care about gefore experience mucking my games up :|

    Try that and

    reboot,

    try the audio again!

    Hope this helps
Ask a new question

Read More

windows 10 Nvidia