Dual monitor setup was working, now it stopped

My Rig:
intel i74790k quad core
asus Z97-A ATX LGA1150 motherboard
G.Skill Ripjaws X Series 16gb DDR3-1600 memory
Asus Geforce GTX 970 STRIX Video Card


My main monitor is running on displayport and my second monitor is running on a dual link cable.

I have a Brand new Asus VG248QE
and a older HP monitor.

The dual displays was working fine for the last few months. The other night I fell asleep with netflix running. When I do this I turn my main monitor off (The Asus) and run netflix on my second monitor. To my surprise when I moved my mouse to wake my computer back up the display settings were all fucked up. My main monitor wasn't working saying "no signal found." And the resolution/scaling on my second monitor were all messed up.
In display settings it wouldn't let me save any changes saying "unable to apply settings." The identify monitors only recognized my second HP monitor. I thought maybe display port was messed up so I unplugged the cables and replugged them in. It didn't fix it. So now I'm running a single monitor on my Asus using my dual link cable from my HP monitor.


It can't be the display port cable because it is brand new, and it is rarely moved or even touched. How do i fix this? Been trouble shooting for hours with no success. I have installed most up to date nvidia drivers. Tried to setup dual monitors through display settings and nvidia graphics control panel, neither worked. I also did a system restore and that also didn't work. Running out of ideas.
1 answer Last reply
More about dual monitor setup working stopped
  1. Wow after several hours of troubleshooting I disconnected my power cord from my asus monitor and plugged it back in and all of a sudden my display port is working... Problem solved guys. Hope this helps someone in the future
Ask a new question

Read More

Asus Dual Monitors Monitors