Solved

CPU speed at 0.48Ghz during low battery, despite adjusting power settings

Hi,

On my laptop, I have noticed that the CPU speed is dramatically reduced from 1.98Ghz to 0.48Ghz whilst low on battery. As soon as I plug the laptop in, the CPU speed returns to 1.98Ghz. This loss of CPU speed has a great impact on system performance, rendering the laptop near useless.

My laptop is running an Intel Core i3, and I believe that the technology which controls the speed of the CPU is called SpeedStep. There is no option in the BIOS to turn this feature off. I have also tried to change this setting in the 'Power Plan' options (in Windows). I changed the minimum processor state to 100% and the cooling policy to 'Active'.

I would like to keep my CPU running at 1.98Ghz. Any suggestions?

(see this photo for clarification)

Many thanks.
9 answers Last reply Best Answer
More about cpu speed 48ghz low battery adjusting power settings
  1. what laptop do you have?

    its generally advised to leave it on as it prolongs life of CPU - http://www.overclock.net/t/1166043/how-do-i-completely-disable-speedstep
  2. Hi there,

    Many thanks for your reply.

    My laptop is a Lenovo Yoga 500 15 inch, with 4GB of Ram and an Intel Core i3 5005U processor.

    I understand that SpeedStep does have its advantages, but on my laptop, the decrease in CPU speed renders my computer almost useless. For example, the laptop cannot even play a YouTube video when the CPU speed decreases to 0.48Ghz.

    Have you got any suggestions to turn SpeedStep off completely?

    Many thanks.
  3. Best answer
    Quote:
    problem solved by going into the Bios and disabling intel virtualization technology... Try it out


    Quote:
    A small update. It seems that turning the computer off (not restarting) and starting with the charger plugged in makes the computer start in the right configuration (meaning that the cpu is not stuck at 0.49GHz). It looks like it is working everytime I have the issue. While this is definitely still not acceptable it makes the computer less useless... Still hoping that an update will come and fix that!


    Quote:
    I have found a usable workaround for this:

    Set the power button to put the laptop into hibernate
    Make sure the laptop is plugged in or the battery has a decent amount of charge
    Press the power button to go to hibernate
    Wait a while until the light on the light on the power button goes out
    Press the button to turn it on
    Of course 1. only has to be done once

    This should get you back to normal operation. It works as in hibernate the laptop turns off completly. This clears the error


    this seems a common problem with Yoga's

    See if anything in here will help: Lenova link
  4. Great! Thanks for the information. I will try this in the morning and post the results.

    Many thanks
  5. I think that I am getting somewhere!

    Unfortunately, none of the solutions that you provided made any difference. However, after looking at the Lenovo forum that you linked, I believe that I have found the solution.

    This was the solution:
    Quote:
    I have spent a long time looking into this issue and it appears that the fault is not directly with Lenovo. However, there are steps you can take to remedy it.

    BD PROCHOT (Bi Directional PROCessor HOT) is a warning on Intel processors that allows the rest of the machine (both hardware and software) to throttle the CPU. It is designed as a precaution against overheating in small form factor machines, like the Yoga 500 series as discussed in this forum post.

    There are no built-in ways to remedy this, no version of BIOS currently available for this series allows the user to disable the warning, and no operating system I am aware of is able to turn it off by default. Therefore power settings do not affect it as the warning is lower-level than the operating system.

    The setting for changing this warning is located at position 0x1FC on the CPU register, decrementing the value at this address by one (for example: address value is 262239, change it to 262238) turns off the warning.

    On Windows operating systems this is not necessary as ThrottleStop (available at the link at the bottom of this post) is capable of disabling the warning.

    Again, the problem is NOT anything to do with the operating system, and therefore screenshots of power settings are useless. No BIOS versions provided by Lenovo for these systems allow the user to turn off the warning.

    As for recreating the throttling at ~30% (the threshold may be slightly lower) there are no special steps to be taken. Simply allow the laptop to use its battery until it is very low, and then observe the CPU throttling. An easy way to tell whether the system is throttling is to try to scroll on a webpage in Google Chrome. The framerate will not be smooth. You can also open Command Prompt on any Windows system and use the command "wmic cpu get CurrentClockSpeed" to confirm that the clock speed of the CPU is significantly lower than it would usually be. For example, the i5-5200U processor on my 15IBD system is supposed to be capable of 2.2 GHz, but when throttling it was limited to 500 MHz, less than a quarter of what it should be running at.

    BD PROCHOT is a system warning intended for maintaining safe operating temperatures, but it appears to be enabled when charging or on low battery for power saving purposes, as neither of those states should affect the temperature of the machine and I cannot imagine why else it would be activated.

    I am not sure if the fault lies with Lenovo or Intel, but hopefully you will be able to liaise with Intel in order to remedy this issue.

    I would have provided screenshots and BIOS versions but I used ThrottleStop to work around the issue six months ago, as shown by my last post in this thread. I do not currently have the laptop with me. In lieu of that I hope that the information I have provided has been useful, and please contact me if I can be of any further help. I have spent a long time trying to solve this issue and would like to be able to help others solve it more quickly.
    (click here to go to the Lenovo forum page)

    I found that this problem is very common among Lenovo laptops, and the only way to solve it is to download a program called ThrottleStop and turn off the 'BD PROCHOT' setting. This had an immediate effect: my laptop is now below 30% (this is the point that it previously throttled) and running at the full 1.98Ghz. Let's hope that my issue is now resolved.

    Thank you very much for your help, as without the link you provided, I would not have found the solution. :D
  6. That is probably something lenova designed into laptops as you wouldn't think they use an Intel CPU without knowing what its features are. throttling when on low power is a way to extend battery length at expense of performance. If that app works, at least you have a choice now.

    I didn't know if they help, i figured something in that forum would though :)
  7. Agreed, it was probably a 'feature' designed for the laptop. Certainly a poor design though!
  8. I am glad my CPU has plenty of air flow so it never gets stuck at .81 which is slowest it goes. Originally when i got PC i had an overclock on it so max for 4.4ghz and some samsung software had PC running at 100% CPU all the time. I don't need that much speed all the time. So I had opposite problem.

    Be pleased to know it can still happen to skylake CPU

    downside to disabling it is PC might get hotter than it did before.
  9. You can set your CPU speed state on the advanced power options...
Ask a new question

Read More

Battery Laptops Speed CPUs Power