Clean install problems, probably simple fixes

Hey guys, did my first clean install of win 7 premium today

Went fine and now its back to default settings etc and wiped clean, but now my noob side shows and theres lots of little steps Im stuck on..

For starters my 1080p monitor now wont display in 1080p anymore and windows doesnt show that as an option, only lower resolutions, I assume I need to install something for my gfx card (nvidia settings or something) to fix this issue?

Internet: I cant seem to figure out how to connect back to the internet, I plug the ethernet directly to the pc but I cant find how to log back into my modem etc and get back online, probably really simple but its lost on me lol

And is there any other basic things/programs I should be adding after a full clean install? I have only installed windows again thats all
6 answers Last reply
More about clean install problems simple fixes
  1. Probably need to download the drivers for the Ethernet card from the motherboard's Web site. Every time I install Windows 7 Pro 64Bit, there is no internet connection due to no drivers were installed.

    Same thing with the graphics card, more than likely you need to download the drivers for your GPU.
  2. Please give us the model number of your motherboard and graphics card so that the more experienced members can give you specific directions.
  3. My specs:
    ASrock H77 Pro4-m

    Nvidia geforce GTX 660
  4. Have you installed the drivers for your motherboard? That's the first thing you have to do after installing the OS. If you don't have the driver CD/DVD you'll have to download the drivers from the manufacturer's site. http://www.asrock.com/mb/Intel/H77%20Pro4-M/?cat=Download

    Since you cannot connect to the internet yet, you'll have to download the drivers with another computer. If you have to use someone else's computer to do the download, I suggest you download the LAN driver first and install it in your computer. After that, you'll be able to connect to the internet and download the rest to your own computer.

    Not being able to set the monitor resolution properly is also probably caused by the absence of the driver for your graphics card. Windows 7 has only a rudimentary graphics driver. Since the card is NVidia-based, you can download the driver from their site. http://www.geforce.com/drivers
  5. Pimpom said:
    Have you installed the drivers for your motherboard? That's the first thing you have to do after installing the OS. If you don't have the driver CD/DVD you'll have to download the drivers from the manufacturer's site. http://www.asrock.com/mb/Intel/H77%20Pro4-M/?cat=Download

    Since you cannot connect to the internet yet, you'll have to download the drivers with another computer. If you have to use someone else's computer to do the download, I suggest you download the LAN driver first and install it in your computer. After that, you'll be able to connect to the internet and download the rest to your own computer.

    Not being able to set the monitor resolution properly is also probably caused by the absence of the driver for your graphics card. Windows 7 has only a rudimentary graphics driver. Since the card is NVidia-based, you can download the driver from their site. http://www.geforce.com/drivers


    Many thanks man! and yeah I have another pc to download from in the meantime, Ill give this all a go and post again later
  6. Success! all issues gone now, thanks guys!
Ask a new question

Read More

Clean Install