Laptop Graphics Confusion

Hi All

I have a Lenovo Z70-80 laptop, tech specs state : Graphics Up to NVIDIA GeForce 840M 2GB - which is why I chose it.

Once up and running I discovered it has on board Intel(R) HD Graphics 5500 as well as a separate NVIDIA GeForce 840M

The NVIDIA settings were set to Automatic and pretty much 100% of the time was using the on board Intel but I soon discovered how to use the NVIDIA control panel and set it so that the video editing programs always used the NVIDIA card.

So, fast forward 2 years, I have installed the software for my Thinkware dashcam and the video plays but stutters. I then remember the NVIDIA control panel and set it so that dashcam software uses NVIDIA rather than Intel but the video will not play in the Thinkware software (sound but black screen) under these settings. They will play in Windows media player even when the NVIDIA is set for all programs. They are MP4 files.

Any suggestions appreciated.
Reply to MiniEmma
2 answers Last reply
More about laptop graphics confusion
  1. See if Lenovo had updated drivers for the video card (Do not check nVidia support, laptops tend to have issues when you use reference video drivers). If that does not help, see if there is newer software for your dashcam or try using some other program to play the files.
    Reply to hang-the-9
  2. hang-the-9 said:
    See if Lenovo had updated drivers for the video card (Do not check nVidia support, laptops tend to have issues when you use reference video drivers). If that does not help, see if there is newer software for your dashcam or try using some other program to play the files.


    Thanks hang-the-9, I had indeed already updated via nVidia so have now updated via Lenovo but nothing changed unfortunately.

    I've tried some other dashcam software and some play ok and others don't. I'll persevere :)
    Reply to MiniEmma
Ask a new question Answer

Read More

Laptops Nvidia Lenovo Geforce Graphics