problem on my system

Hello so on the 20/3/17 i got a big problem, mainly my device, so on that night i got a update on win 10 about Realtek - LAN - Realtek PCIe GBE Family Controller. i got a pop up saying it can't be install(• Realtek - LAN - Realtek PCIe GBE Family Controller - Error 0x80070002), so i went and retry it but still fail, then i went into the device manger and try to update from there (i am not too sure if is called the same like the update says) but no luck there so i uninstalled it and restarted my computer. After that i went into the device manger then it say on 'other devices' Ethernet controller with a triangle with a Exclamation mark it say,
The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.


To find a driver for this device, click Update Driver.
I try update it and it says
Window encountered a problem instilling the driver software for your device
Says it found the driver but encountered a error
then it show realtek PCIe GBE Family Controller
The system cannot find the file specified

So i try and went into realtek website my mother board website to try and install the driver but no use so i try to do a reformat and even that did not work and i try instill the family controller on my disc and that not work but it say that is is install (family controller) so idk wat to do i believe that the reformat did not work cause i uninstall that and windows can't automatic instilled it
PLZZZ help i am so lost, i am 14 and not a tec nerd i hope someone can help me !
P.S i know i am not really met to be on this site but i need help
Reply to fireboy16
2 answers Last reply
More about problem system
  1. I have seen another question similar too this already today. My advice is to reboot while holding shift. follow THIS-->https://www.howtogeek.com/235474/how-to-roll-back-builds-and-uninstall-updates-on-windows-10/ Link and roll back an update. If that does not work try too find the driver for your model on the manufacturer's website and download to other computer and transfer it via USB.
    Reply to nathanstrainrocks
  2. Thx for your response but I was about to updated news on this event today but now I don't have any Wi-Fi cause I uninstalled my driver Cause of at the same night I try to updated my Wi-Fi (USB wireless wifi ) but it did not work with the same error but I download from the website instilled but turn out to be the same version so I unstalled the latest dated one (20/3/17)then that problem happened but there was a pattern after I reinstall (DVD driver for Wi-Fi) it I still was not getting any Wi-Fi check on devices manger and sure enough I have the same problem like the family controller were it found the driver but can't instill it so now IDK want to do now I can't have Wi-Fi
    But thx for your response
    Reply to fireboy16
Ask a new question Answer

Read More

Devices manger Realtek USB Realtek - LAN - Realtek PCIe GBE Family Controller - Error 0x80070002 Realtek - LAN - Realtek PCIe GBE Family Controller Devices Controller Wireless Adapter error reformat Ethernet Controller