Sign-In Migration Megathread

Hey there Tom's Community people!

In our ongoing efforts to improve cybersecurity, we'll be making changes to the way users sign-in to the forums starting today, August 10th. As such, every one of our users will be logged out of Tom's Hardware, and all cookies will expire during the migration.

When the migration takes place, it will mark the beginning of Phase 1 (tentatively scheduled for late this week or early next week Aug 10th-14th). Once it is live, to ensure a seamless transition and to preserve your current password, simply log in to your Tom’s Hardware account between now and August 16th. You'll be able to do so by selecting the link in the upper right-hand corner of the site, or by heading to the login page directly once it is live. The new service provides better encryption, so it’s a no-brainer for the security-minded.

Please note that during the migration period, registration and account recovery emails may be delayed by several minutes, so we ask for your patience in this regard. Additionally, please be sure to check your spam folders as sometimes emails end up there.

To sweeten the deal and ensure everyone comes along, we’re running two back to back Summer Giveaways worth thousands of dollars in prizes, including epic and legendary hardware, steam gift cards, and tech that we know you want. For the first of these massive summer giveaways, look no further than right here: http://www.tomshardware.com/forum/id-3493436/tom-hardware-builds-giveaway.html

Cybersecurity is everyone’s responsibility, and we’re taking active steps to safeguard your security and privacy with this change on Tom’s. Thank you in advance for your attention to this!

Please use this this mega-thread for any questions or concerns regarding the sign-in service migration and how it can affect your account. Stay tuned for additional details as the timeline for the roll-out of the account migration becomes more clear, as we'll be sharing that with you right here.

Warm Regards,
The Tom’s Community Team

Quick Solutions

Q. I'm getting 500 server errors when I try to log in / log out / navigate the site. Help?
A. Delete your cookies and clear your cache.

Q. The password reset option doesn't work and I can't get into my account.
A. Certain accounts have an issue associated with them that we're hoping to fix in short order. No worries though, your account is safe. If you are someone who has an account and can't use the reset password option, shoot us an email at community@tomshardware.com and we'll add your name to the list of those we're tracking with this problem.

Q. I can't change my email address / my email address is old and I can't log in.
A. Shoot us an email at community@tomshardware.com and we'll process the request manually to change your address once the migration phases have completed.

Q. I didn't get a registration / confirmation / notification email!
A. Check your spam folder and/or different tabs in your email provider and be sure to whitelist us. Be sure to check your account settings for your email preference on notifications.
146 answers Last reply
More about sign migration megathread
  1. Are the Summer Giveaways limited to U.S. residents only?
  2. Giveaways are awesome
  3. Quote:
    Are the Summer Giveaways limited to U.S. residents only?


    Yes. You can read why, here.
    http://www.tomshardware.com/forum/id-2969283/tom-contests.html

    That said, we're working with our legal team on a method to add the UK to the contest availability, but this is in the very early stages, quite tentative, and still super contingent on the nuances of contest operations in the UK.
  4. jpishgar said:
    Quote:
    Are the Summer Giveaways limited to U.S. residents only?


    Yes. You can read why, here.
    http://www.tomshardware.com/forum/id-2969283/tom-contests.html

    That said, we're working with our legal team on a method to add the UK to the contest availability, but this is in the very early stages, quite tentative, and still super contingent on the nuances of contest operations in the UK.


    The UK is irrelevant to me. I live in Canada which is directly next door to the U.S. Will you ever sweeten the deal for us Canadians?
  5. ko888 said:
    jpishgar said:
    Quote:
    Are the Summer Giveaways limited to U.S. residents only?


    Yes. You can read why, here.
    http://www.tomshardware.com/forum/id-2969283/tom-contests.html

    That said, we're working with our legal team on a method to add the UK to the contest availability, but this is in the very early stages, quite tentative, and still super contingent on the nuances of contest operations in the UK.


    The UK is irrelevant to me. I live in Canada which is directly next door to the U.S. Will you ever sweeten the deal for us Canadians?


    Tom's is actually a CIA op to make you rise up in rebellion against the Canadian government and join the USA.
  6. Hmmm. Where I work, I can't log into Tom's Guide at all, nor into the UK mirror. I hope the new login system doesn't make things worse; maybe I'll get lucky and it will fix ALL of that... (I'm sure it's not a TH issue; security is very tight where I work, which is a Good Thing).
  7. i was wondering why no-script was refusing to let me log in .... new scripting log ^^
  8. Us residents only, i get that for shipping hardware and stuff , but i mean... codes for steam games can be claimed worldwide :D

    and if not , can the winner decide to give the prize to another reader?
  9. superninja12 said:
    Us residents only, i get that for shipping hardware and stuff , but i mean... codes for steam games can be claimed worldwide :D

    and if not , can the winner decide to give the prize to another reader?

    All of this can be found in the Giveaway Rules once the sweepstakes are open.
  10. Help!!

    Having not read this thread I logged in to my previous account, Hello man, one which I had written like 5+ tutorials on and spent lots of time on (like 200 solutions). I got an email saying "thanks for registering" and freaked, as my account was totally empty. Then it wouldn't let me in. So, I reset my password. It worked, but now it tells me when I use the new or old password that my credentials are incorrect. Naturally, I am freaked, so I created a new account to desperately plea for help. It is currently telling me my account has been blocked after multiple login attempts. Wtf is going on? Help!!!
  11. Onus said:
    Hmmm. Where I work, I can't log into Tom's Guide at all, nor into the UK mirror. I hope the new login system doesn't make things worse; maybe I'll get lucky and it will fix ALL of that... (I'm sure it's not a TH issue; security is very tight where I work, which is a Good Thing).


    Same. I made a new account to get support. My old account, Hello man, is totally locked up. I reset my password and it now says every password I try is wrong.
  12. test

    update: okay for a bit I wasn't able to post any comments.
  13. Rowan_4 said:
    Help!!

    Having not read this thread I logged in to my previous account, Hello man, one which I had written like 5+ tutorials on and spent lots of time on (like 200 solutions). I got an email saying "thanks for registering" and freaked, as my account was totally empty. Then it wouldn't let me in. So, I reset my password. It worked, but now it tells me when I use the new or old password that my credentials are incorrect. Naturally, I am freaked, so I created a new account to desperately plea for help. It is currently telling me my account has been blocked after multiple login attempts. Wtf is going on? Help!!!

    Hey there, don't worry. Old accounts are not going anywhere. You will be able to access your old account even if you're locked out currently and none of the info is getting deleted. To be clear this migration is for log in information. We are not migrating the Best Answer database or anything like that. Please send me an e-mail from the one registered with Hello man and we will get this sorted out for you.

    Sorry forgot to include my e-mail jsimenhoff@purch.com
  14. This new sign on system definitely needs some tweaking. Every time I close the browser I'm logged out. This didn't happen previously. I was able to come and go at will. There isn't a "Stay logged in" checkbox available.

    In addition. The title page no longer indicates that there are new posts since last check in, I have to go to the Forums page before I get any indication. Last check-in there were 4 new messages that didn't show.
  15. ex_bubblehead said:
    This new sign on system definitely needs some tweaking. Every time I close the browser I'm logged out. This didn't happen previously. I was able to come and go at will. There isn't a "Stay logged in" checkbox available.

    In addition. The title page no longer indicates that there are new posts since last check in, I have to go to the Forums page before I get any indication. Last check-in there were 4 new messages that didn't show.


    Same. But it only logs me out of the home page, I'm still logged in the forums. Brand new so maybe just some early teething issues. ( Hopefully )
  16. ex_bubblehead said:
    This new sign on system definitely needs some tweaking. Every time I close the browser I'm logged out. This didn't happen previously. I was able to come and go at will. There isn't a "Stay logged in" checkbox available.

    In addition. The title page no longer indicates that there are new posts since last check in, I have to go to the Forums page before I get any indication. Last check-in there were 4 new messages that didn't show.

    The migration system will delete your cookies. Please see the original message at the top of this thread:
    Quote:
    As such, every one of our users will be logged out of Tom's Hardware, and all cookies will expire during the migration.

    The new log in system is now actively being deployed so there will be some expected hiccups as we QA.
  17. I noticed that I can't log out while on the forums after logging in with the new system, I had to go back to the main page to logout. i got an error 500 I believe.

    Also when I DO log in with the new system it's pulling old old info about me from somewhere:
  18. Can you elaborate as to what you mean "pulling old info about me from somewhere"?
    The more details, the better.
    -JP
  19. jpishgar said:
    Can you elaborate as to what you mean "pulling old info about me from somewhere"?
    The more details, the better.
    -JP


    My Tom's username isn't Just Me Soraka, I'm not exactly sure where it's pulling that from, because I haven't gone by that in a long time.
    Also I believe T3CH/xXD3athXx said it was showing his full name.
  20. MERGED QUESTION
    Question from WildCard999 : "TH Forum Logout"

    Every time I try to edit/answer a question I'm getting logged out of TH, any other users experiencing this?
  21. _Johnny5 said:
    Rowan_4 said:
    Help!!

    Having not read this thread I logged in to my previous account, Hello man, one which I had written like 5+ tutorials on and spent lots of time on (like 200 solutions). I got an email saying "thanks for registering" and freaked, as my account was totally empty. Then it wouldn't let me in. So, I reset my password. It worked, but now it tells me when I use the new or old password that my credentials are incorrect. Naturally, I am freaked, so I created a new account to desperately plea for help. It is currently telling me my account has been blocked after multiple login attempts. Wtf is going on? Help!!!

    Hey there, don't worry. Old accounts are not going anywhere. You will be able to access your old account even if you're locked out currently and none of the info is getting deleted. To be clear this migration is for log in information. We are not migrating the Best Answer database or anything like that. Please send me an e-mail from the one registered with Hello man and we will get this sorted out for you.

    Sorry forgot to include my e-mail jsimenhoff@purch.com


    Email sent.
  22. Rowan_4 said:
    _Johnny5 said:
    Rowan_4 said:
    Help!!

    Having not read this thread I logged in to my previous account, Hello man, one which I had written like 5+ tutorials on and spent lots of time on (like 200 solutions). I got an email saying "thanks for registering" and freaked, as my account was totally empty. Then it wouldn't let me in. So, I reset my password. It worked, but now it tells me when I use the new or old password that my credentials are incorrect. Naturally, I am freaked, so I created a new account to desperately plea for help. It is currently telling me my account has been blocked after multiple login attempts. Wtf is going on? Help!!!

    Hey there, don't worry. Old accounts are not going anywhere. You will be able to access your old account even if you're locked out currently and none of the info is getting deleted. To be clear this migration is for log in information. We are not migrating the Best Answer database or anything like that. Please send me an e-mail from the one registered with Hello man and we will get this sorted out for you.

    Sorry forgot to include my e-mail jsimenhoff@purch.com


    Email sent.



    Yay! Such success. I don't know if you did anything, but if you did, thanks a bunch!
  23. WildCard999 said:
    MERGED QUESTION
    Question from WildCard999 : "TH Forum Logout"

    Every time I try to edit/answer a question I'm getting logged out of TH, any other users experiencing this?


    i am also experiencing this issue. i'm still playing with other browsers and options to see what may be causing it.

    i am using firefox but am trying it with a couple others to see if it is firefox related or not. but at this point whenever i click "update this" to edit one of my posts, it logs me out and returns me to the main page.

    when i inspect the button element i see this
    <a href="/logout" data-href="#" class="crLink"><span>Update this</span></a>

    it looks like somehow this button has been linked to the logout feature though my html knowledge is pretty basic so i may be mis-interpreting what i am seeing
  24. Math Geek said:

    i am using firefox but am trying it with a couple others to see if it is firefox related or not. but at this point whenever i click "update this" to edit one of my posts, it logs me out and returns me to the main page.

    when i inspect the button element i see this
    <a href="/logout" data-href="#" class="crLink"><span>Update this</span></a>

    it looks like somehow this button has been linked to the logout feature though my html knowledge is pretty basic so i may be mis-interpreting what i am seeing


    That's odd. For me it's an actual edit link, but takes me to a different page than the one I get when clicking the edit button to the right. I haven't actually logged out and back in yet so maybe it's behaving differently for me because of that.
  25. Testing, 1. 2. 3. :)
  26. For me it is the edit/reply feature that is causing the log out. I'm using Chrome on Windows 10.
  27. WildCard999 said:
    For me it is the edit/reply feature that is causing the log out. I'm using Chrome on Windows 10.

    It's completely OS/browser agnostic. I've tested in Windows and Linux with IE, Edge, Firefox, Opera & Chrome and it happens everywhere.
  28. Hey there all,

    Please be aware, if you do send a request to the system to reset your password, it may possibly take a bit of time for that email to arrive (potentially upwards of 5 minutes) as this was an issue reported earlier in the process that may or may not have cropped up during the migration. Please bear with.

    -JP
  29. I was unable to log in earlier today. I tried changing password, and no luck. I could log into the tom's main page, but would get 500 errors in the forum section. I also noticed that it was showing my old email address, when I logged in with my username. I used the google link, as I now have gmail, and was able to log in that way.
  30. hmm, also jsut got an email about the migration that... maybe is lacking some info?
  31. Yours is a little messed, due to the Google Account sign-up function and naming issue discussed earlier.
    Otherwise, just consider that we consider you dear to us. :P

    -JP
  32. No issues from my end. Sorry to be so boring :)
  33. Damn, if only I remembered that my login name is screwed up from the last migration/update, then I might find I could actually login to make a comment. The system here is really odd compared to other websites. Maybe this new method might be better, but somehow I doubt it.
  34. Nice to see security updates, however it would be nice to know what urls we need to keep our cookies for.
    Some of us have cookie cleaners and knowing which cookies (urls of) maintain our login would be useful.
  35. No problems here using Slimjet as a browser (have not tried it on Firefox). I've only noticed a couple of minor annoyances:

    1) When trying to respond to articles, there's no option to go to the forum comment format (where you can edit, etc.). It's just the generic commenting interface.

    2) My username and avatar on the main website and on said generic commenting utility show up with my email and email avatar (Google/Gmail), not my Tom's Hardware username and avatar (10tacle, F/A-18E). When commenting on forums, everything is normal. Confused the heck out of me at first.
  36. Ok, so I just logged in using Brave Browser without any problems. So once I have logged in, I'm good right? My credentials will be in the new system?
  37. only the login page is https, is this intended?
  38. Quote:
    My username and avatar on the main website and on said generic commenting utility show up with my email and email avatar (Google/Gmail), not my Tom's Hardware username and avatar (10tacle, F/A-18E). When commenting on forums, everything is normal. Confused the heck out of me at first.


    Your email address itself isn't exposed, correct?
  39. jpishgar said:
    Your email address itself isn't exposed, correct?


    Correct. I meant email name just to be more clear. I checked using another computer not logged in just to be sure. It's just showing for me when logged in for whatever reason (and again, it's only on the front main page and when in articles typing responses, not in the forum discussion like this).
  40. just tested a handful of my old posts and i can now edit them without being logged out and returned to the main page :)

    thanks for the quick fix

    i now get this when inspecting that element
    <a href="http://www.tomshardware.com/forum/edit/20053628" data-href="#" class="crLink"><span>Update this</span></a>

    hopefully it's fixed for everyone
  41. DeLorean 2017 said:
    Ok, so I just logged in using Brave Browser without any problems. So once I have logged in, I'm good right? My credentials will be in the new system?


    oasis789 said:
    only the login page is https, is this intended?


    jpishgar said:
    Quote:
    My username and avatar on the main website and on said generic commenting utility show up with my email and email avatar (Google/Gmail), not my Tom's Hardware username and avatar (10tacle, F/A-18E). When commenting on forums, everything is normal. Confused the heck out of me at first.


    Your email address itself isn't exposed, correct?


    Yaaa-Hooo ... in FF w/bunches of add-ons
    All good, here, and the Quote function works for the first time in 10 years (?) ...

    On what may or may not be a completely unrelated matter, I did have some rather nasty 'TSL Handshake' issues yesterday -- here, and everywhere else after 2PM EST or so

    Quick edit -- be good
  42. Hey there all!

    TIP: If you are experiencing difficulty signing in with your username, please try using the email you signed up with instead.

    Known/Reported Issues:

    • "0AUTH Error: Redirect URL is wrong" issue where this error is received upon attempted login.
    • Username and Avatar on article comments and login screen shows email nickname from Google instead of Tom's username and avatar.
    • The link to "Comment from the Forums" is missing in article comments from editorial pages.
    • Random difficulties signing-in using username and password. (See above tip for workaround.)
    • Login issues for Internet Explorer 11, generates a blank screen.

    There are naturally a few hiccups with the transition, so we ask your patience in bearing with us as we work out the bumps in this migration. Devs have been notified of these issues and we hope to have them resolved soon.

    -JP
  43. MERGED QUESTION
    Question from doh : "Login to Tom's on IE11"

    doh said:
    Login to Tom's on IE11
    When I try to login to www.tomshardware.com as instructed in the email, I get a black screen or page (not a black screen crash), and get no further (when I login on Firefox I get the same black screen, but shortly after a lodin screen appearson top of that and I can login) Is there a compatibility problem with IE11 (Windows 7 Home Premium)

    Doh!
    12.August.2017
  44. -
  45. If you can't log out you can probably force it by deleting cookies for tomshardware.com (or .co.uk). I can't say for certain but I suspect the cookie named "sso.tomshardware.com-sso" is the culprit.
  46. How about the nonworking email thing? Is that something that will ever be fixed?
  47. When will the summer giveaways begin? And do we receive emails when they start? I don't want to miss them.
  48. SinxarKnights said:
    I am unable to sign out of the forums and i haven't gotten an email from toms in years (since the last migration).

    For the first one, if i click sign out in the forums i am taken to the front page where it says im logged out. however if i visit the forum i am still signed in.


    Same here. First day after migration, when I was trying to Log out, I was always seeing error 500. Now it works as SinxarKnights described.
    Funny enough, I can log in and out of Toms guide without problems.
  49. DRagor said:
    SinxarKnights said:
    I am unable to sign out of the forums and i haven't gotten an email from toms in years (since the last migration).

    For the first one, if i click sign out in the forums i am taken to the front page where it says im logged out. however if i visit the forum i am still signed in.


    Same here. First day after migration, when I was trying to Log out, I was always seeing error 500. Now it works as SinxarKnights described.
    Funny enough, I can log in and out of Toms guide without problems.

    Have you tried this fix suggested by Randomizer?

    If you can't log out you can probably force it by deleting cookies for tomshardware.com (or .co.uk). I can't say for certain but I suspect the cookie named "sso.tomshardware.com-sso" is the culprit.
Ask a new question

Read More

Tom's Hardware