Solved

No signal to monitors from GPU and integrated graphics

Both of my monitors have no signal from my PC. I have tried:
- Using a different PSU I know works
- Using integrated graphics
- Clearing CMOS
- Swapping RAM
- Running without drives plugged in.
And still nothing. I know the monitor works as when plugged into a friends laptop it turns on. Any more ideas?
10 answers Last reply Best Answer
More about signal monitors gpu integrated graphics
  1. Forgot to add specs:
    PSU: Corsair VS 550W
    Mobo: Gigabyte AB350M - Gaming 3
    CPU: AMD Ryzen 5 1600 six core
    RAM: 16gb DDR4 2133MHz
    256 GB SSD and a 1TB HDD
    Running Windows 8.1
  2. New, or old setup?
  3. A bit of both. The Mobo, Ram, CPU are part of a bundle I got 3 months back. The PSU is 1 month old. I've had the monitors for years. The graphics card is the oldest part (AMD HD 6970). It has been running fine the past few months and has stopped today.
  4. Do the fans spin when starting the board? Can you connect an internal speaker to the motherboard?
  5. Fans spin, and system speaker gives a short beep. Mouse + Keyboard lights come on and they both respond. i.e. I can turn capslock on and off.
  6. Best answer
    Try testing different graphics card, if possible. It could be a power supply issue too. Always test with monitor connected to the graphics card, not to the motherboard.
  7. I'll have to look around a bit to see if there is a spare graphics card around. Thanks for the quick replies.
  8. No problem.
  9. My new graphics card arrived and now everything works fine. I still don't know why integrated didn't work. Thanks for the advice.
  10. No problem. The integrated does not work because the CPU does not feature integrated graphics. You'd need an APU.
Ask a new question

Read More

GPUs Monitors Graphics