Solved

Monitor not working properly at 144Hz

When I got this monitor (Acer Predator XB241H) three days ago, I immediately set it to 144Hz. It has worked fine for browsing and gaming (it's been brilliant), but when I'm browsing now, it seems a lot less smooth. I decided to do this online refresh rate test (https://www.testufo.com/) and it said that my display is running at 60hz. It is set to 144Hz everywhere: In Windows and in NVIDIA control panel. What can I do? It was running perfectly smooth even this morning, and now it seems to scroll more like my 60Hz display in Firefox. It is now the same story in Discord: It seems to scroll a lot less smoothly than it did previously. I'm really unsure about what to do.

It also seems to run fine in games. In Rocket League, I had it set to Borderless Window and it seemed to be jittering a lot. I then changed it to fullscreen with improvements. But I was not seeing these problems a couple days ago.

I appreciate the help, thanks a lot! If you need any more details, please let me know.
7 answers Last reply Best Answer
More about monitor working properly 144hz
  1. Try using Firefox instead of Edge. Mine did the same thing, but when I tried it on Firefox it read 144hz fine.
  2. I am using Firefox and I was when the monitor was working. Now it still seems jittery.
  3. I really need a solution to this, otherwise this is £400 that I've completely wasted
  4. Best answer
    have you tried to change the cable itself or the cable port ? try this and hope it solve your issue
  5. Yeah, I was thinking of trying another DP cable. After all, this cable was one that came with the monitor and probably isn't of the highest quality. Thanks for your help, I really appreciate it.
  6. There we go, using a new cable seemed to improve it. I'll keep you updated if necessary.
  7. glad to hear that , hope it's solved bro.
Ask a new question

Read More

Acer Monitors Predator