Sign in with
Sign up | Sign in
Your question

Can´t enable AHCI in Bios

Last response: in Motherboards
Share
June 29, 2011 10:29:13 PM

Hi
I have just bought an Intel 320 160GB SSD, and before i install W7, i want to enable AHCI. But the only setting i´ve found is the setting "Raid mode", where i can choose between IDE, Raid and AHCI. I have tried to change it to AHCI but the system would´nt boot then.
A video of all the bios settings can be found here: http://www.youtube.com/watch?v=yhKXhu1LFiA

My motherboard is an MSI 870A-G54 and i have updated the bios using MSI Live Update.

I appreciate all the help I can get
Thanks

More about : enable ahci bios

June 29, 2011 10:53:54 PM

You may need to install windows in IDE mode first, then switch to AHCI mode. There are plenty of tutorials on how to do it...just use google. That is what I ended up having to do with my new Vertex 3. Also, make sure you have the latest firmware on your ssd.

When you say your system wouldn't boot in AHCI mode, do you mean it wouldn't POST? (I am assuming that as it seems you haven't installed windows yet) If so you may want to contact MSI.

I'm no expert and I am afraid that is all I can think of...hopefully someone else who knows more will post.

Good Luck!
June 29, 2011 11:02:06 PM

senkasaw said:
You may need to install windows in IDE mode first, then switch to AHCI mode. There are plenty of tutorials on how to do it...just use google. That is what I ended up having to do with my new Vertex 3. Also, make sure you have the latest firmware on your ssd.

When you say your system wouldn't boot in AHCI mode, do you mean it wouldn't POST? (I am assuming that as it seems you haven't installed windows yet) If so you may want to contact MSI.

I'm no expert and I am afraid that is all I can think of...hopefully someone else who knows more will post.

Good Luck!


Hi
Ok, that sounds like a good idea.

I was actually using my old HDD with Windows 7, and it did go to POST, but it had a bluescreen that lasted for about 1 sec. and then it failed to boot Windows. I guess that the AHCI setting in my Bios isn't the one that i should have changed.

But thanks anyway, tomorrow i will try to switch to ACHI after i have installed Windows :) 
Related resources
June 29, 2011 11:16:14 PM

Ah, there are some registry entries that need changing in Windows before it will boot in AHCI mode...if those entries aren't changed then you do get a BSOD that flashes for about a second.

Have you tried switching it to AHCI mode with just the SSD attached and installing Windows? If that works then Windows will install the correct drivers when it installs (no need to change registry entries).
June 29, 2011 11:21:49 PM

Ahh now i understand.. Haven´t tried to boot with the SSD since my DVD-reader is broken, so i cant install Windows from a disc..

Will try that tomorrow :) 
June 29, 2011 11:25:40 PM

It looks like your BIOS doesn't even have the option for AHCI. Is that right?

Select RAID mode and try it. In most cases, enabling RAID also enables AHCI.
!