Sign in with
Sign up | Sign in
Your question

Can´t play videos on new Nvidia AGP cards

Last response: in Graphics & Displays
Share
March 24, 2007 2:37:14 PM

Hi there, I know many people have this same problem:

I had an AGP 6600 GT card, and everything worked fine with the 81.95 forceware drivers.

When I switched to later drivers, I couldn´t play videos with any media player at all. The system was almost frozen, and I had to use the task manager to exit the media player.

So I re-installed the older drivers, and everything went back to normal.

BUT…

Now, the 6600 card died, and I just bought a 6700 GS, AGP. Drivers older than 91.31 won´t support this card, so the video playing problem is here again.

I have researched countless hardware forums (even this one), and many people has the same issue with the new AGP cards and the recent Forceware. But no solution was given at those threads.

Some forumers point to power supply unit problems, others to codecs, and others to the AGP drivers for the mother board.

As far as I know, it is a Forceware driver problem. Here is a list of things that I have ruled out:

I think POWER is not the problem: my old 6600 GT AGP would play videos with the older drivers, but not with the new ones.

I think CODECS are not the problem, for the same reason as above.

About the AGP drivers for the mother board, the Service Pack 2 for Windows XP installs Microsoft drivers for that purpose, so my MOBO´s manufacturer stopped providing new AGP drivers, and the last ones it provided – from 2003 – don´t work (I have tried them out, and video starts playing, but the system completely hangs after a moment).

So far, I understand that the new AGP cards are really PCI-express cards adapted to the AGP slot. And the new Forceware has overlooked some kind of conflict or malfunction, that was corrected in 81.95 and before. But I´m just guessing.

I have looked at Microsoft, Nvidia, Aopen, Asus and VIA websites, and this problem is not considered, even though, as I said, many users suffer from this.

I would really appreciate any feedback. If you had the same issue and found the solution, please let me know, or please point me to the link or links that may help.

Thank you very much in advance.

My system relevant specs are:

CPU: AMD Sempron 2800 (2 GHz) (equivalent to Athlon XP 2800)

MOBO: Aopen AK77-600GN (VIA chipset)

OS: Windows XP pro (Service Pack 2)

2 GB of RAM

PD: I posted this same thread in the graphics card generic forum to increase the chances of a reply. Sorry for any inconvinience.
Related resources
March 24, 2007 3:34:28 PM

One workaround is to go into the display properties/settings and click the advanced button. Go to the troubleshoot tab and take the hardware acceleration down from full to half way. Video will play fine then.

I had this problem on my quadro fx3500 as well as the other people that I work with who had the same card. We updated to the 91.36 version of drivers for this card and the problem went away. Have you tried updating to the most recent drivers for this card (just asking because some people dont update first)
March 24, 2007 3:54:45 PM

Hi, thanks for the quick answers

Nuke:

Yes, I have tried the latest VIA drivers, but with no results.

Bennie:

You had the same problem, and you solved it?. How did you? I am playing games fine. Is only with videos that I have this issue.

Horstmann:

Mmm yes it plays videos when hardware acceleration is set to none or 1/6th, but my CPU is not fast enough to play smoothly in large windows or full screen mode. The main problem remains.

And yes, I have tried all ForceWare versions from 81.95 to 93.71 (the latest).

I am reading somewhere else that it could be related to the system recognizing the AGP card as a PCI card, and that someone[/list] solved it with an application named “Powerstrip”. I installed this app but I am afraid to do some damage to the hardware.

Any more suggestions? Thanks again.
March 24, 2007 4:29:34 PM

I had that problem on a buddy's box and solved it by trying an old v78.05 release, can't remember where I d/l'd it... here is one

old nvidia forceware drivers
March 24, 2007 4:40:52 PM

Try go here and download and install the modded driver
March 24, 2007 4:42:49 PM

Hmm, strange. I have an AGP 6600 (Non-GT or GS) and havent experianced this issue. I've had it where videos wouldnt play, but I think that was an overlay problem, and I cant quite recall how I solved it. Using the latest drivers here, and still no issues so far. The card is even overclocked to PCI-E speeds (The AGP cards are so very underclocked, use RivaTuner to bring them back up to proper performace levels. Oh, and watch the heat if you have a tiny OEM heatsink :D  )

All modes have 550MHz mem speed

Standard 2D mode - 400MHz Core (Should be 300, but I was bored. I know it makes sod all difference)
Low power 3D core speed is 300MhZ (Cant be changed)
Performance 3D Ccre speed is 530MHz (Over the original 300)
March 24, 2007 6:19:06 PM

Rongak:

Thanks, I am looking at those modded drivers, but none say anything about this prob. If no one comes with a proved solution, I will give´em a go.

Cable:

Quote:
Hmm, strange. I have an AGP 6600 (Non-GT or GS) and havent experianced this issue. I've had it where videos wouldnt play, but I think that was an overlay problem, and I cant quite recall how I solved it


But that´s the part I am most interested in! Can´t you try to remember how did you solved it? I will think about overclocking once I have the card up and running properly. Thanks for the tips anyway.
March 24, 2007 9:04:04 PM

Did you try a driver cleaner?
I didnt notice that this had been tryed sorry my bad on the games tho.
I once had a dvd burner that went from burning 12 x to about 1 x couldnt figure it out, untill I formatted and installed xp again yes corrupt drivers will do this to hardware.
Good Luck
March 24, 2007 9:07:39 PM

Power strip is a overclocking tool
March 26, 2007 3:17:52 PM

Hey there jjmcrj!

I had the exact same problem as you until just a few minutes ago. It was realy depressing to spend hours of downloading drivers, codecs, moded drivers and reading tons of forums just to find nothing there, figure it out by myself and see how embarrassing simple it is. So here it is (sorry if names are wrong, I happen to have the german version of the driver):

- Open your nvidia control panel
- go to Video & TV settings
- go to change video color
- move the "coloring" (the third slider from above if name is wrong) one percent to the right (or basicly whatever percentage you wish to whatever direction - you can also set it back afterwards)
- apply changes
- have fun watching videos again :) 

Hope it works for you too.
sup3rior

[edit]Erm... okay this only works as long as you have the control panel open. As soon as I close it, it's green again. No Idea. Working on it :/ 

[edit 2]Okay, couldn't work around that. But however it works now for me with the following solution:

-Download the NGO moded drivers earlier linked by aBg_rOnGak (I had version 1.9792)
- Open the (old) nvidia control panel
- Go to Video Overlay Settings
- Check the following box: "Enable VMR"
- Finaly enjoy your videos again ;) 
March 26, 2007 3:51:57 PM

Hi sup3rior:

I did that, and at first I was amazed, bsplayer started playing the movie...

...but it played it like there was no harware acceleration (pixelation, slow framerate...). Then I started google earth, and 3D was extremely slow (like a slideshow). Then, when I went to check wether the hardware acceleration was on, it was. So I decided to turn it off and then on again, but as soon I moved the slider to the left, the system crashed badly (just by moving the slider, I didn´t even apply the changes).

I guess that this is just another proof that there is a serious driver compatibility issue (mobo - graphichs card).

Has the same happened to you? Does your system work ok now?

Thank you.
March 26, 2007 4:08:04 PM

Hm... that's odd, JJ.

No, I don't encounter any of these problems you describe. I checked it out: movies play normal, I can change and apply new hardware accelerations without problems and google-earth runs normal.
So I guess my system works normal with the NGO moded drivers and VMR enabled.

My System Spec:
3GHz Pentium 4
2GB DDR
Asus P5GDC Deluxe
GeForce 7800 GTX
March 26, 2007 4:47:26 PM

ok, so I will install NGO version 1.9792 (is this the one you had before, or the one that you have now?)

And a couple more questions please:

did you system detect a PCI card before the solution, and an AGP after fixing?

what does "VMR" stand for? Thanks again.
March 27, 2007 3:32:17 PM

Hey, sorry for late response, had to take off yesterday.

To your questions:
Yes, I have NGO version 1.9792 now. I had standard nvidia drivers before. I believe it was 93.something, not exactly sure.

Quote:
did you system detect a PCI card before the solution, and an AGP after fixing?

Sorry, I realy don't know. But I had never any problems that I would relate to that.

And sorry again, I have no clue what VMR stands for. I was just frustrated and "tried around" ;) .

By the way: could you make it work with the NGO drivers and VMR enabled?
March 31, 2007 9:51:15 PM

Thanks Sup3rior.

Sorry for not answering, I´ve some time away from computers. I will try your suggestion when I find some time, and I will let u know.

See ya
!