Skip to main content

Raspberry Pi OS Offers New Features, Breaks USB Booting

New Raspberry Pi OS
(Image credit: Tom's Hardware)

Along with releasing a new 8 GB Raspberry Pi 4 model yesterday, the Raspberry Pi Foundation made a couple of noteworthy changes to its OS strategy. The company changed the name of its first-party operating system from Raspbian to "Raspberry Pi OS" and released a 64-bit OS beta to go with the existing 32-bit platform.

The newly-christened Raspberry Pi OS has a few new features, which the Pi Foundation highlighted in a blog post today. A new, preloaded Bookshelf app provides a huge library of works from the Raspberry Pi Press—including a complete collection of MagPi, HackSpace, and Wireframe magazine issues. You also get access to a number of free books.

In an effort to improve accessibility for sight impaired, Raspberry Pi OS also has a new feature called Magnifier. It helps enlarge elements on the screen to improve visibility. The new tool is available in the Recommended Applications under Universal Access.

The team also implemented a new questionnaire that will appear when launching Chromium from a newly installed image. It's a brief option survey of questions they hope will provide insight into what the user base is looking for in the OS. To read more about the new features, visit the official Raspberry Pi website.

The update fixes a few bugs but inadvertently created a new issue with the USB bootloader beta. The new Raspberry Pi OS beta uses incompatible *.elf files that will cause a USB boot drive not to boot anymore. The solution is to grab the older *.elf and *.dat files from Raspberry Pi's May 22nd firmware github repo.  Check out our article on how to boot a Raspberry Pi 4 Off a USB SSD or Flash Drive to see both how to do it and how to fix the problem. 

To updated your existing install to the new version of Raspberry Pi OS, you just need to enter the following commands in a terminal window.

sudo apt update
sudo apt full-upgrade

You will then need to reboot. The magnifier doesn't install automatically with the update so you'll need to enter the following command to activate it.

sudo apt install mage
  • irianr43
    Looks like you did the same as me - not read the installation requirement carefully enough particularly the command
    sudo rpi-eeprom-update - this command checks for newer version and does not update
    To update use
    sudo rpi-eeprom-update -a
    Boot from usb will now work under the new OS
    Reply