Skip to main content

You Can Launch SteamVR Beta With The Controllers, But Beta Update May Cause Display Issues (Update: Issue Resolved)

Update, 7/14/16, 7:34am PT: Valve has addressed the issue causing the display to show a solid color with an update. It is safe to switch back to the beta branch of SteamVR.

Valve recently released SteamVR beta 1467913359, which adds the ability to launch SteamVR by powering on the Vive controllers. Unfortunately, the update also introduced a display problem, so it’s probably not worth the update yet.

I was going to wait until the stable version of the update was released before reporting on how well it works, but I wanted to get an early jump on things, so I downloaded the beta over the weekend. Upon launching SteamVR for the first time with the new update, I noticed that the Vive wasn’t tracking properly. The software launched, but SteamVR said it couldn’t track the headset, even when it was being moved around. A simple restart of SteamVR seemed to fix the issue, so I didn’t think much of it.

The next time that I opened up SteamVR, the headset was tracking fine, but it still wasn’t working properly. This time, I noticed that the left lens was lit up more than the right. A closer look revealed that the left display wasn’t working. It was on, but the only thing I could see was solid gray. Restarting SteamVR temporarily fixed the issue, but it comes back from time to time. 

The display has gone gray while launching games and also in the compositor. The problem seems to be intermittent. I haven't been able to lock down a trigger for it at all, despite trying every possible combination of variables that I can think of. Restart "start VR" command. Close it while running something. Launch the app right after booting the PC. Those are all situations that resulted in the left screen not turning on, but I could not replicate the error in any of those cases.

A quick search through the SteamVR community comments section and the r/Vive subreddit revealed that I’m not the only person to have experienced this problem. It appears to be a fairly common occurrence, judging by the discussion on Reddit, though the problem is intermittent at best.

We came across the issue while using a GTX 1080 Graphics card, and after several tests, I believe that it (and possibly other pascal GPUs) is the only card that suffers from this issue. Throughout the weekend, I ran tests for another upcoming article with a variety of GPUs, including Nvidia's GTX 970, 980 and 980Ti, as well as AMD's R9 390, 390X and Fury. The display has never been a problem with any of those other GPUs.

To be fair, the display issue crops up rarely. In my attempt to replicate the problem, I restarted SteamVR dozens of times. The left display was gray for only three of those cases. Even when the display is a problem, it usually re-calibrates within a few seconds. I've witnessed a game load in one display only once.

It's easy to avoid the display problem completely, though. All you have to do is stay on the stable branch of SteamVR releases. The standard release is not subject to this problem. You'll be missing out on the ability to launch SteamVR by turning your motion controllers on, but then again, you've never had that ability before. Valve will eventually release the feature to everyone.