Skip to main content

Antec Aria AR300 PSU Repair

Progress

I replaced the 22µF with a 33µF FC and, guess what?

The negative peaking across the photocoupler's output (VCE) is mostly gone and the 5VSB output came down to a noisy but sensible value. I doubt the feedback signal is supposed to be this noisy and the main outputs are still dead: no response of any sort to tying PS_ON# to ground. Related or coincidental issues?

Where the heck do those negative spikes across the photocoupler come from and why are they still there? Looks like my initial guess about EC3 simply being a feedback filter capacitor may have been wrong. Time for some more reverse-engineering to see exactly how it is wired up.

Interesting. Instead of powering the primary-side feedback circuitry from the same auxiliary output as the main controller chip, the photocoupler has its own dedicated auxiliary output, and EC3 turned out to be the filter capacitor of that dedicated supply. In place of the usual rectifier diode, the circuit leverages the zener's forward conduction to clamp reverse polarity and avoid the extra part, albeit at the expense of a few extra resistors. I could not find a silkscreen designation for the 2.7kΩ resistor, but if you want to find it on the board pictures, it is hidden inside the piece of shrink tubing between a transformer pin and one of R71's pads on the bottom side.

Why does EC3/AUX2 have such an odd circuit configuration? My guess is that the separate high-impedance circuit for the feedback supply capacitor was intended to protect the capacitor from high ripple current so it can prevent potentially catastrophic 5VSB output voltage excursions long after the other outputs' capacitors went bad, but got ruined by ZD4 roasting EC3. Had EC3 been located away from potentially extremely hot components like ZD4, it should have succeeded at preventing the 5VSB output from rising to abnormally high voltages in the presence of good capacitors on the 5VSB output. The engineers at ChannelWell had the right idea but failed on the actual implementation by overlooking a simple board layout detail.

This explains why the photocoupler's output did not seem to make any sense with the busted capacitor in place. Without a decent amount of charge to maintain positive bias between -170V and AUX2, voltage on AUX2 simply ends up following whatever the transformer puts out, and this includes reverse polarity during the forward half of the switching cycle when the primary winding is being driven.

I still do not like the noise across VCE. Based on voltage across the photocoupler's diode, I would expect current through the phototransistor and its VCE to be relatively steady. Also, the 5VSB output got noisier with the replacement capacitor.

Daniel Sauvageau is a Contributing Writer for Tom's Hardware US. He’s known for his feature tear-downs of components and peripherals.