Skip to main content

CrossFire-on-a-Stick

Benchmarks Results

3DMark05

When running on the Intel D975XBX motherboard we were able to enable CrossFire in the Catalyst 7.3. The odd thing happened when we ran the first series of tests of 3DMark05 with antialiasing and anisotropic filtering disabled. We normally run the feature tests in addition to the three game tests. When the first run ended the third game test, 3DMark05 abruptly ended to the desktop with an error message. We then ran the test exactly the same once more when the identical crash happened. We then tried to only run the features test separately but the same crash happened again. Obviously there is an issue running the feature tests.

We then proceeded to run only game tests. After the first test at 1024x768 the scores looked very good for the Sapphire X1950 Pro Dual as it was able to stay in line with a GeForce 8800GTX breaking 16,000 marks. Another oddity occurred when the resolution of 1600x1200 was selected. The scores came back almost exactly halved from what we would have expected them to be. We ran the test several more time, rebooted the system, and even disabled and re-enabled CrossFire to make sure there wasn't an error we could fix easily. It seemed as if the second graphics processor was not being utilized. Once at a higher resolution setting the anomaly disappeared.

Moving to the higher image quality setting yielded a similar behavior at 1600x1200. This led us to believe there is an issue with the driver. Without direct support from AMD, Sapphire will be on their own to solve this issue and all the others we have encountered.